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1 Xebra E-Commerce Overview

Your Xebra E-Commerce Advantage subscription entitles you to features in the Xebra Client software
that you can use to manage a web site hosted by Xetex.  The combination of the E-Commerce
features in the Xebra software and the web server allow you to provide multiple web portals for your
customers to log in, place orders, and view information that you want them to see.  

You use the Xebra Client software to build catalogs of products that you offer based on the items that
are already in your Xebra database.  Xebra is specialized to provide a way for you to offer printing,
promotional products, items that you warehouse for your customers, and office supplies.  You can
make catalogs that are specific to your customer's company as a whole, or you can make catalogs
that are specific to individual web users within the company.  The Xebra Client software also offers
many ways that you can customize the look and functionality of the web portal for each company or
person that logs into your Xebra web site.

This Xebra E-Commerce documentation is divided into the following 5 major parts:

1. Xebra E-Commerce Overview - The current section that you are now reading.

2. Initial Setup - This section provides step by step instructions to get you started.  If you are new to
Xebra E-Commerce, you definitely need to look at this section first.

3. Learning By Example - This section describes step by step how to configure a customer's web
portal.  Because E-Commerce requires a web server and a Xebra database to be working closely
together, the Xebra Tutorial does not cover E-Commerce.  The Learning By Example section provides
a workaround so that you can carry out tutorial-like steps with your live system in order to get familiar
with Xebra E-Commerce basics.

4. Advanced Setup Options - This section covers topics such as assigning a domain name to your
Xebra E-Commerce web server and acquiring a secure SSL certificate for your Xebra web server so
that your web site can work with sensitive data such as credit card numbers.  This section also
describes all the ways that you can modify the look and functionality of your web pages.

5. Xebra E-Commerce Reference - This section describes in detail all of the Windows, menus, and
data fields that are used to manage Xebra E-Commerce web sites.
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2 Initial Setup

When you first start a Xebra E-Commerce Advantage subscription, Xetex should provide you with two
things:

1. Xetex should enable the E-Commerce features in your Xebra Client software.
2. Xetex should setup a web server for you and give you a public Internet IP address for that web
server.

Before you begin using Xebra E-Commerce, you should test to make sure that Xetex has completed
the above steps.
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2.1 Verify E-Commerce Availability In Xebra Client

Log into your Xebra Client and look at any Go menu.

If the Go > E-Commerce menu item is enabled, then the E-Commerce features are already enabled in
your software.  

If the E-Commerce menu is disabled (grayed out), then you need to install an update to enable the E-
Commerce features.  In the Go menu, choose Setup to load the Xebra Setup window.

On the Xebra Setup window, choose Actions > Check for Update from the menu.

NOTE: If Check for Update is disabled, you will need to find a person at your company who
has the correct Xebra operator security privileges to perform these steps.

On the Check for Update window, you should be able to leave the Xetex Update Server section
unchanged.  Just hit the Continue button to see if an update is available.  If an update is not available,
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contact Xetex Customer support to find out when your E-Commerce features will be ready for you.
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2.2 Verify E-Commerce Web Server Availability

Once you have made sure that the E-Commerce features are available in your Xebra Client, the next
step is to see if your web server is ready.  Xetex should provide you with an IP address for your web
server.  Go into a web browser, enter the IP address in the address bar of the browser, and hit the
Enter key on your keyboard.  If the web server is running and you have the right IP address, you
should get a blank page with the title "New Xebra Web Site".

If no page loads for your address and you don't see the title "New Xebra Web Site", contact Xetex
Customer support to find out when your E-Commerce web server will be ready for you.
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2.3 Establish Commincation With Web Server

Once you have established that the E-Commerce features are available in your Xebra Client and your
web server is running, the next step is to make sure your Xebra Client software can communicate with
the web server.

In the Xebra Client, select E-Commerce from the Go menu to load the main Xebra E-Commerce
window.

At the top of the Window in the Web Site Address prompt, enter the IP address that Xetex gave you
for your web server.  Click the Refresh Web Site button below the Web Site Address prompt.  If
everything is working, you should see a message "Please Wait...Refreshing Web Site..." and then you
should see a message similar to "Your web site was updated with 80 new files."  If you receive an
error, it may mean that Xetex did not finish configuring your new web server and you should contact
Xetex Customer support to find out when your E-Commerce web server will be ready for you.
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2.4 Set Your E-Commerce Logo Image

The Refresh Web Site button on the main Xebra E-Commerce window transfers settings that you
make in the Xebra Client software and data from your Xebra database to your web server.  If you have
done this first refresh without making any E-Commerce configuration changes in your Xebra Client,
your web server will contain bare minimum defaults.  If you reload the web page for your E-Commerce
IP address at this point, instead of getting a blank page with the title "New Xebra Web Site", you
should see a simple log in page similar to the following:

Notice that in the web page, there is a missing image marked with a rectangle with a red X in it.  This
is a place holder for your company logo image.  To set your logo image, choose the Actions > Default
Appearance menu item from the main Xebra E-Commerce window.
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This will bring up the E-Commerce Default Setting window.

In the lower right hand corner of the E-Commerce Default Setting window is a button with the caption
"Your Company Logo".  Click this button to bring up the Internet Logo File window.

You will need to produce an image file for your logo and you might want to include other information on
the image such as your address and phone numbers.  You should save your logo image file as a JPG
file or PNG file.  The dimensions of the file should be appropriate for the web pages that it will display
on.  Keep in mind that you can change your logo image file at any time, so your logo image doesn't
have to be perfect before you can try it out.
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Once you have an image file, click the Add button on the Internet Logo File window to open your logo
image file.  The image will be loaded into the Internet Logo File window.

Click the OK button to save the image and close the Internet Logo File window.  Also, click the OK
button to close the E-Commerce Default Setting window.

After you have made changes to E-Commerce images or other settings, you will have to click the
Refresh Web Site button on the main Xebra E-Commerce window to make the changes active on your
web site.

Once you complete the Refresh Web Site action you can reload your web page with your Xebra E-
Commerce IP address and you should see the simple login page with your logo image on it.
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3 Learning By Example

This section describes step by step how to configure a customer's web portal.  Because E-Commerce
requires a web server and a Xebra database to be working closely together, the Xebra Tutorial does
not cover E-Commerce.  The Learning By Example section provides a workaround so that you can
carry out tutorial-like steps with your live system in order to get familiar with Xebra E-Commerce
basics.  There are several ways that you can approach this Learning By Example section:

1. Follow along and enter the data into your live system exactly as described.  This is probably the best
way to avoid frustration when getting started with Xebra E-Commerce.   For purposes of
demonstration, we will pretend that Xetex Business Systems, Inc. is your new customer that you want
to setup.  Wherever artwork files or other images are needed to complete steps, there will be a link for
you to download the artwork file from www.xebra.com.  At the end of the Learning By Example section
are instructions for removing the test data that you entered into your live system so that this data
doesn't clutter up your live system.

2. A more ambitious way to approach this Learning By Example section would be to pick one of your
real customers and try to set them up according to the steps in this section.  This approach could lead
to frustration because many of the things done in this section likely won't apply to your real customer
and you will want to do things differently for your real customer than the way it is described in this
Learning By Example section.  If you choose to go this route, treat this customer setup as a test rather
than shooting for perfection.  Keep in mind that you can modify the customer setup at any time and
you don't have to have it exactly the way it should be until its time to give your customer their login
information.

3. If you are in a real hurry, you could just read through this section and not follow the steps at all.  
This section contains numerous screen shots so you can gain a lot by simply reading and you don't
necessarily have to complete the steps in your live system; however, there is a definite benefit to
learning by doing.

http://www.xebra.com.
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3.1 Customer Setup

Each customer site that you setup for E-Commerce must have a Master Customer record in your
Xebra database.  The first step is to go to Xebra Order Entry > View > Customer > Shipping, make
sure you have a master customer record entered, and make sure you know the code.

Go to  Xebra Order Entry > View > Customer > Shipping.

Choose Commands > New from the menu on the Customer Shipping window.

On the New Code window enter XETEX for the new customer code.
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Click the OK button on the New Code window to create the new Customer Shipping record and enter
the following information:

Name: Xetex Business Systems, Inc.
Address 1: 1103 Rocky Drive
Address 2: Suite 103
City: West Lawn
State: PA
Zip: 19609
Phone: 610-898-1551
Fax: 610-898-1564
Email: frh@xebra.com
Contact: Fred Hickey
Salutation: Fred
Sales Rep: Pick any sales rep that you have in your system.
Master Customer: XETEX

Notice that both the Customer Code and the Master Customer Code are XETEX on this
record.  Xetex only has one location, so this is the only customer shipping record for the
XETEX master customer.  If Xetex had multiple ship to locations, there would be multiple
customer shipping records but they would all have the same Master Customer Code - XETEX.
 E-Commerce is centered on the Master Customer code when you setup a customer's web
portal.

Tax Location: PA (If you don't have PA entered as a tax location in your live system, it won't hurt
anything to use another Tax Location that you already have for this example.  You do have to
enter something for the Tax Location but it doesn't have to be accurate for this example.)

Billing Reference: XETEX

When you get the message, "The code 'XETEX' does not exist.  Create New?", answer Yes to create
the new Customer Billing record.  You can accept the default information for the new Customer Billing
record and just close the Customer Billing window.

Your completed master customer record for Xetex Business Systems, Inc. should look like the
following:
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Once you have the Master Customer record setup, your are ready to go to Xebra E-Commerce to get
the web portal setup for this customer.  Choose E-Commerce from the Go menu to load the main
Xebra E-Commerce window.  Then choose Actions > Customer setup.

This will open the Customer Setup window.
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In the Master Customer prompt, enter the Master Customer code for the site that you want to
configure.  In this example, the code is XETEX.

Once you enter the Master Customer code and press Tab or Enter on your keyboard, the Create Client
Internet Files button will be enabled.  You need to click the Create Client Internet Files to initialize a
web portal for a new customer site.  After you click the Create Client Internet Files button, the caption
of this button changes to Web Site Appearance and all of the other elements on this window that were
previously disabled are now enabled.
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At this point, the XETEX master customer is setup with a bare minimum default web portal, but no one
would ever know because nobody can log in.  Each customer site that you setup needs to have at
least one Web User setup so that they can log in and make use of the site.  Click the Web Users
button near  the lower left corner of the Customer Setup window.  This will open the Web Users
window.
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To add a web user, choose Commands > New from from the menu.

The Master Customer for the new Web User defaults to the Master Customer that was selected on the
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Customer Setup window when you opened the Web Users window.  The password defaults to a series
of random characters.  For now, let's set the User Name to fhickey, the password to something easier
to remember like fred, and the Real Name to Fred Hickey.  This is the absolute minimum information
required for a web user to log in to the site.

Although other fields are highlighted as important on the Web Users window, with just the User Name,
Password, and Real Name filled out, you can see what the new XETEX web site looks like so far. 
Close the Web Users window, close the Customer Setup window, and click the Refresh Web Site
button on the main Xebra E-Commerce window.  After the refresh completes, in your Web browser
reload the page with your Xebra E-Commerce IP address.  Enter fhickey for the User ID, enter fred for
the password, and click the Log On button to see what the site looks like so far.

The web page that displays won't have much on it yet.  There are no catalogs setup yet for this web
user to order from.  The only thing you can see so far that is configured is your company logo, the real
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name of the web user fhickey in the part of the page that says "Welcome Fred Hickey", and a very
bland logo image for Xetex Business Systems, Inc. that was created automatically when you clicked
the Create Client Internet Files button.  The logo image for your customers that is created
automatically should definitely be replaced.  Hopefully, you can get artwork files from your customers.

To change the customers logo, go back to Xebra E-Commerce > Actions > Customer Setup, enter the
Master Customer: XETEX, and hit the Tab or Enter key on your keyboard.  Click the Web Site
Appearance button to load the E-Commerce Settings For Master Customer: XETEX window.

This window is almost identical to the E-Commerce Default Setting window, but the E-Commerce
Settings For Master Customer window is specific to a Master Customer.  Settings made on the E-
Commerce Settings For Master Customer window override any settings made on the Default Setting
window.  The Default Setting window only defaults the settings for new customers.

Click the Customer's Logo button to open the XETEX Internet Logo File window.

The image shown in this window is the automatically generated image that was made when you
clicked the Create Client Internet Files button.  Click the Replace button and open another image file to
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use instead.

If you are following along, you can download another image from:
http://www.xebra.com/Artwork/XetexLogo.png

Once you replace the customer's logo file, you can go back to the main Xebra E-Commerce Window,
click the Refresh Web Site button, and after the refresh is complete you can check the progress of
your web site.  If you still have the browser open to the XETEX customer Welcome page, you can just
refresh the page.  If you don't still have your web site open in a browser, you will have to enter your
web server IP address into the browser again and on the login page enter fhickey for the user and fred
for the password.

The Home page for customer XETEX should now have the new logo.

http://www.xebra.com/Artwork/XetexLogo.png
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3.1.1 Adding A Warehouse Catalog Item

In this section, we will add an item to the web site that is stored in a warehouse managed by Xebra
Customer Specific Inventory.  First, the item must be entered into Xebra Order Entry > View > Item.  

For this example, we'll use a #9 Window Envelope with the Xetex logo and return address. 

From the Item window menu, choose Commands > New

On the New Code window, enter XETEX-ENV-9W for the new Item code and click the OK button to
create the new Item record.

Enter the following information on the new record in the Item window.

Description 1: White #9 Window Envelope
Description 2: Imprinted Logo & Address

Customer: XETEX
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Packed: 500 EA Per BX

Sell Unit of Measure: BX
Buy Unit of Measure: BX

Since this product will be stored in a warehouse and managed by Customer Specific Inventory, click
the Customer Specific Inventory Item check box and enter BX for the CS inventory unit of measure. 
By using BX for the CS unit of measure, you are saying that this item will always be released in BX
units without exception.

Click the image button to add a picture of a printed envelope.  

You can download a picture of the printed envelope from:
http://www.xebra.com/Artwork/XETEX-ENV-9W.png

After you Add the image, you should have a fairly high resolution picture of the envelope.

By adding the image to the item record before creating the E-Commerce catalog item, you are saving
a step when it comes to creating the E-Commerce catalog.

Your completed item record should look like this.

http://www.xebra.com/Artwork/XETEX-ENV-9W.png
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Once you have the item record, you can move on to configuring the item for storage in a warehouse
managed by Customer Specific Inventory.  Close the Item window and use the Go menu to go to
Customer Specific Inventory.

To create a control record for them item in a warehouse, choose Commands > New from the menu on
the Xebra Customer Specific Inventory window.
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On the New Control Record window, enter XETEX-ENV-9W for the item code.  The warehouse code
used in this example is WHS01 but if you are following along you could substitute another warehouse
code if you don't have one with the code WHS01.

After you click OK to save the new control record, be sure to fill in XETEX as the Master Customer
code on the Xebra Customer Specific Inventory window.  Also, click the Bill as shipped check box. 
When you're done, your new control record should look something like this:

In order to show an available quantity on the web site, you will have to receive some of these
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envelopes into the warehouse.  From the Actions menu, choose Receive.

Answer No to the question, "Would you like to take information from a previously created job?" and
select the item XETEX-ENV-9W at the warehouse location in the Pick A Destination Control Record
dialog.

On the Receive dialog you only have to enter a Quantity of 10 for this example.  You can leave the rest
of this dialog blank.
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Click the OK button to save the receipt record and answer No to the question, "Receive another
item?".

Notice that up to this point, we haven't done anything in E-Commerce to add this item to a catalog so
that the web user can place an order for it online.  Whenever you setup an E-Commerce catalog item,
its good to make sure that the base item record exists and the information on it is as complete and
accurate as it can be before you add the item to an E-Commerce catalog.  In the case of Warehouse
item catalogs in E-Commerce, you need to make sure that the CSI control records are in good shape
too before you add the items to E-Commerce Warehouse catalogs.

If the background item information in your system is good, its easy to add the items to E-Commerce
catalogs.  Use the Go menu to switch to the Xebra E-Commerce window and choose Actions >
Customer Setup from the menu.

Enter XETEX for the Master Customer code in the Customer Setup window and hit the Tab or Enter
key on your keyboard to load the setup information for XETEX.  Then, click the Master button in the
Warehouse Release section of the Catalogs section.
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On the Warehouse Release Master Catalog window, Click the New Item button.

On the New Warehouse Release Master Catalog Item window, choose the XETEX-ENV-9W item.

NOTE: If you had multiple CSI items to add to this catalog, you could select multiple items on the New
Warehouse Release Master Catalog Item window and add them all at once.

Now that the item is in the Master Catalog, you should see it in the list on the Warehouse Release
Master Catalog window.  

Select the item in the list to bring up the Warehouse Release Catalog Item window.



Learning By Example 31

© 2009  Xetex Business Systems, Inc.

The description, unit of measure, and packing description defaults from the information in the base
item record.  You could potentially change this information to be displayed different on the web site. 
One thing that you should change is the Small Image.  There are two images for each E-Commerce
item.  The Small Image should be thumbnail sized so that it can display in a list on a web page.  The
Large Image can be much bigger to show more detail of the product if the web user is interested.  The
image that you attached to the item record will be the default for both the small and large image on this
E-Commerce master catalog item.  The size of the image for the Large Image should be OK, but you
will want to shrink the Small Image.  

Click the Small Image button on the Warehouse Release Catalog Item window.  You will see that the
resulting image in the Small Image window will be too big for a thumbnail.



Xebra E-Commerce32

© 2009  Xetex Business Systems, Inc.

Click the Reduce Size button to bring up the Resize Image window.  

For this example, change the Pixel Height to 100 and hit Tab or Enter on your keyboard.   Since the
Maintain Aspect Ratio check box is checked, you will see that the Pixel Width adjusts in proportion to
the Height, so when the Height is set to 100, the Width will change to 213.

After you click the OK button on the resize Image window, you will see the new shrunken image.
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Click OK on the Small Image window to save the reduced picture.

One other thing that you should set is the price per BX of this bill as shipped item.  Set the Unit Price to
40.00, then click the OK button to save the changes to this Warehouse Master Catalog Item. 

Close the Warehouse Release Master Catalog window to return to the Customer Setup window.

Below the Master button in the Warehouse Release section, you will see a button labeled User.  

Click the User button in the Warehouse Release section to bring up the Warehouse Release User
Catalog window.
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The Master catalog is a list of items that are configured for a customer that can be used in a User
catalog.  Web users are assigned to particular User catalogs to define the products that the web user
is allowed to order.  User catalogs are often a subset of a Master catalog, but it is possible to assign all
items in a Master catalog to a User catalog.  If your customer is a large company with multiple
divisions that will be ordering from you, you might set up a different user catalog for each type of
person that will be ordering from that company.  In cases like this, you might assign a User catalog to a
web user that only contains items from the master catalog that are relevant to the web user's role in
the company.  Another approach would be to create multiple user catalogs with each catalog
containing particular categories of items.  Then, for each web user you would assign all the user
catalogs that contain items of the type that the web user would want to order.

In this example, we just want to create a single User catalog that contains the one item that we have
configured so far in the master catalog.

From the Warehouse Release User Catalog menu, choose Commands > New

For the Description on the new user catalog, enter: Xetex Warehouse Items

Click the New Section Description button and for the Section Description enter Envelopes and hit the



Learning By Example 35

© 2009  Xetex Business Systems, Inc.

tab key on your keyboard.

So far, the Warehouse Release User Catalog should look like this:

Click the New Items button to display the Warehouse Release Master Catalog Items list.
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Double click the XETEX-ENV-9W item to add it to the user catalog.  The simple user catalog should
now look like this:

Close the Warehouse Release User Catalog window to return to the Customer Setup window.

Now that you have a user catalog, you need to link it to a web user.  On the Customer Setup window,
click the Web Users button to display the Web Users window.

Click the Find icon on the toolbar.

On the Find Web User window, enter fhickey for the User Name.



Learning By Example 37

© 2009  Xetex Business Systems, Inc.

Click the Search button on the Find Web User window and double click the fhickey record in the
Search Results list to load the record.
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Look for the Catalog list near the bottom of the Web Users window.  Notice that it's currently blank. 
You need to add the User catalog that you created to this list.

Click the Add Catalog button to the right of the Catalog list.
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Unless you remember the Catalog ID for the user catalog that you created, click the binoculars to the
right of the Catalog ID prompt on the Web User Catalog window to find your user catalog.

Select the Xetex Warehouse Items catalog from the Find Code list.

Now that the correct Catalog ID for the user catalog is selected, click the OK button on the Web User
Catalog window to add the catalog to the list.  The Catalog list on the Web Users window should now
look like this:

Close the Web Users window.

Close the Customer Setup window.

On the main Xebra E-Commerce window, click the Refresh Web Site button to send your changes to
the web server.

After the refresh completes, reload your web site in a browser.  If you need to log in again use the
fhickey user and password fred.  If you don't need to log in again, simply push the refresh button on
your browser to view the modified web page.

You should now see a new menu item on the web page with the caption, Warehouse Release.
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If you click the Warehouse Release menu item, the Envelopes sub menu appears below which
represents the text you entered in the Section description of the User Catalog.  Below the Envelopes
sub menu, the item appears.  The Item information also appears in the main part of the page, including
the small image for the item.
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If you click on the small image of the envelope, the large image will appear in a pop-up window.

Close the large image pop-up window and return to the main page.  Notice that the On Hand quantity
to the right of the small image of the Envelop is showing 10.  This is the amount that we Received into
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inventory.  Also, the price per box is showing as $40.00.  This is what we entered on the Warehouse
Release Catalog Item window for this item.

In the Quantity box, enter 1.

Click the Add To Cart button.  This will put the item into the Shopping Cart and load the Shopping Cart
page.

Click the Complete Order button to load the Checkout page.
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On the Checkout page enter the following Information:

PO Number: PO123
Cost Center: CC123
Special Instructions: We are out of envelopes so please hurry!

Press the Continue button to complete the order.  You should see the Order Confirmation page.
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In the image that shows the Order Confirmation page, Sales Tax was calculated as $2.40.  If the tax
location code that you used for your demo XETEX customer was not configured the same, the Sales
Tax and Total that you see may differ.

Now that you've placed the order on the web site, go back to your Xebra Client and go to the main E-
Commerce window.
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Notice that the Unprocessed Activity From Web Site is still showing zero orders for each type.  (If you
don't see zero orders on your Xebra E-Commerce window, you must have Real Time processing
already setup.)

Unless you have Real Time processing enabled, you have to click the Refresh Web Site button to
receive orders from your web server into your Xebra database.  For now, just click the Refresh Web
Site button to receive the order.  After the refresh completes, the Warehouse Releases total order
count will change to 1 and the Process Warehouse Releases button will become enabled.

Click the Process Warehouse Releases button to open the Process Warehouse Release window.
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The Process Warehouse Release window shows all of the information that the web user submitted
with the order on the web site.  If you wanted to keep a printed record of this order as it came from the
web site, you could press the Print button to generate the E-Commerce Warehouse Request
document.
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On the Process Warehouse Release window, click the Process button to open the E-Commerce
Warehouse Request Transfer window.
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Notice that the Price is set to 40.00 even though the Price in the list of available lots for the produce is
0.00.  We didn't enter a price for this product when we did the CSI Receipt.  We did set the price to
40.00 in the Warehouse Release Catalog Item window.  The price that you set in the E-Commerce
catalog is used instead of the lot specific price for E-Commerce releases.  This way, the price on the
E-Commerce order should always match what the web user saw on the web site when they placed the
order and it won't matter which lot the of the product that the actual release is drawing from.

Click the Transfer button to complete the release and answer Yes to view the Release information. 
The regular Customer Specific Inventory Warehouse Release Edit window will be displayed.
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From this point on, this release could be processed the same as any Customer Specific Inventory
release.

Close the Warehouse Release Edit window to return to the main Xebra E-Commerce window.  You
should see that Warehouse Releases is now showing 0 unprocessed orders again.

If the Order Confirmation page is still displaying in your web browser, click the OK button to return to
the Home page of your site.  If you closed your browser, log back into the web site with user fhickey
and password fred.

In the Envelopes section you should see that the On Hand quantity is now showing 9.  You started out
with 10 and 1 was released.  Also, notice that the Last Order quantity is showing 1 BX, indicating that
one box was ordered the last time this product was ordered.
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It would be a good idea to remove this test release from your system right away to prevent confusion
that might occur if somebody else in your company sees the release as ready for processing.

Use the Go menu to switch to Customer Specifc Inventory.

Choose Actions > Release Edit/Track from the Xebra Customer Specific Inventory menu.

Choose Commands > Find from the Warehouse Release Edit menu.

Enter XETEX in the Master Customer prompt and hit the Search button.  Load any resulting releases
for XETEX and void them using the red X in the toolbar.

After you void the release go back to the main Xebra E-Commerce window and click the Refresh Web
Site button.

Once the refresh completes, go to your web site and refresh the page with the XETEX-ENV-9W item. 
You should now see that the On Hand quantity is back to 10, because the release associated with the
order was voided.

Notice that the Last Order quantity still shows 1.  Although the release was voided, the record of the
last order remains.
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3.1.2 Adding A Stock Sales Item

The Xebra E-Commerce Stock Sales catalog type has a variety of potential uses:

1. You can use it for items stored in General Inventory.
2. You can use it for items that you buy for your customers on demand.
3. You can use it for items that you produce in house on demand.

If you need to show your customer a quantity on hand value specific for that customer's item, you must
use the Warehouse Release catalog rather than the Stock Sales catalog.  If you want to accept orders
where your customer will specify variable imprint data for the item, you should probably use the
Stationery catalog instead of the Stock Sales Catalog, although it is possible to use the Stock Sales
catalog with item options to handle simple imprint orders such as personalized name tags, pens,
shirts, mugs, or other promotional products.

In this example, the item that we will use will be a postcard.  Xetex sends out postcards to a list of
potential trade show visitors before every trade show that they will attend.  For every mailing, Xetex
consistently uses the same type of 6" x 4" card.  We will setup this item to be a generic "Xetex Trade
Show Postcard".  When the web user submits the orders, it will be up to them to send the new artwork
for the current Trade Show.  The web user will also be able to choose whether Xetex will do the
address labeling and mailing or whether Xetex wants you to do the mailing for them.  If Xetex asks you
to do the addressing and mailing, you will need to be able to accept a mailing list in addition to the
artwork for the postcards.

Also for this example, assume that you always want to send the order to an outside digital printing
company to have the cards printed.  We will create a demo vendor record for a fictional company
called Test Digital Printing Co.

From the Order Entry window, select View > Vendor Ordering.

On the Vendor ordering window, choose Commands > New from the menu.
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On the New Code dialog, enter TESTDIGI for the Vendor Code and click the OK button to create the
new vendor ordering record.

On the new Vendor Ordering record, enter the following information:

Name: Test Digital Printing Co.
Address 1: 123 Main Street
City: Elverson
State: PA
Zip: 19520
Phone: 555-555-1234
Fax: 555-555-1235
Email: orders@testdigitalprintingco.com

When you get to the Remittance Reference...

mailto:orders@testdigitalprintingco.com
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...click Tab or Enter on your keyboard and yes to create a new Vendor Remittance record with the
TESTDIGI code.

Accept the default information on the Vendor Remittance window and close it.

On the Vendor Ordering window, enter the following text for the Notes:

This vendor likes artwork files to be in Photoshop (.psd) format.

Also, check the Pop up notes on entry check box.

With the pop-up notes on entry check box checked, you will get a reminder when you place an order to
this vendor that they accept Photoshop files for artwork.

Your completed vendor record for TESTDIGI should look like the following.
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Close the Vendor Ordering window.

Next, you need to create an item record for the postcard.  Go to Xebra Order Entry > View > Item.  

From the Item window menu, choose Commands > New
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For the new item code, use XETEX-TSPC

Click the OK button on the New Code dialog to close it and create the new Item record.

Enter the following information on the new item record:

Description 1: Xetex Trade Show Postcard
Description 2: 6" x 4" Digital Printing

Customer: XETEX

Sell Unit of Measure: EA
Buy Unit of Measure: EA

Suggested Vendor 1: TESTDIGI

So far, your Item record should look like this:



Xebra E-Commerce56

© 2009  Xetex Business Systems, Inc.

To show an example of what a completed postcard might look like, use an image of a past postcard
mailing.  Click the Image check box on the Item window to display the Image window.  Then, add an
image that shows the front and back of the postcard mailing.

You can download a picture of the past postcard mailing from:
http://www.xebra.com/Artwork/XETEX_TSPC-sample.png

After you Add the image, you should have a fairly high resolution picture of the previously printed
postcard.

http://www.xebra.com/Artwork/XETEX_TSPC-sample.png
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Click the OK button to save the Image and close the Image window.

It would be good to add a more detailed description of this item.  On the Item window, click the Long
description and instructions check box.

This will open the Long Description And Instructions window.  For the Long Description, enter the
following text:

12PT. C-1-S GLOSS COVER WHITE
PROCESS COLOR + UV COATING OVER BLACK - BLEEDS
CUSTOMER SUPPLIED FILES WITH ALL ELEMENTS IN PLACE
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The Long Description is generally meant to be a description that your customer will see.  This
description will carry over to the E-Commerce catalog for this item.

The Vendor Instructions are meant for the vendor to see on the purchase order.  In this case, the long
description also applies to the Vendor Instructions.  Highlight the entire Long Description, right click on
it and choose copy from the pop-up menu.
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Right click on the Vendor Instructions text area and choose Paste from the pop-up menu.

The Warehouse Instructions don't apply to this item since it is not stored in a warehouse, so you can
leave the Warehouse Instructions blank.  Your completed Long Description And Instructions should
look like this.

Click the OK button on the Long Description And Instructions window to save the Long Description and
return to the Item window.

Additionally, it would be good to enter a reminder for the people who will place orders for this item from
your company.

On the Item window, click the Ordering Instructions check box directly below the Long description and
instructions check box.
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This will open the Ordering Instructions window.  Enter the following text:

Place all orders for these postcards with Test Digital Printing Co.  
Remember to have the postcards shipped to us if they need addressing and mailing.  
Adjust the Vendor Instructions for the purchase order to Test Digital Printing Co. so that there is no
reference to addressing and mailing since we will do that.

Click the OK button to save the Ordering Instructions and return to the Item window.

To add pricing for this item, click the Price Information check box on the Item window.

You will be asked whether you want to create a multi-level pricing structure.
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Since the price of this item depends on the quantity, answer Yes to bring up the Multi-level Pricing
window. 

Assume that you have worked with Test Digital Printing Co. before and you know what the unit costs
are at various quantity breaks.  You have also arrived at the prices that you want to charge Xetex.

For quantities up to and including 800, the price per card will be 0.344 and the unit cost will be 0.241.
For quantities over 800 up to and including 1000, the price per card will be 0.335 and the unit cost will
be 0.235.
For quantities over 1000 up to and including 1500, the price per card will be 0.315 and the unit cost will
be 0.221.
For quantities over 1500 up to and including 2000, the price per card will be 0.305 and the unit cost will
be 0.215.
For quantities over 2000, the price per card will be 0.301 and the unit cost will be 0.210.

Enter this information into the Multi-leve Pricing window so that it looks like this:

Click the OK button to save and close the Multi-Level Pricing window.

Your completed item record should look like this:
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Now that you have the Item record, you are ready to create the actual E-Commerce Stock Sales
catalog item.  

Close the Item window and use the Go menu to go to the main Xebra E-Commerce window. 

On the Xebra E-Commerce window, choose Actions > Customer Setup.

On the Customer Setup window, enter XETEX for the Master Customer code and hit Tab or Enter on
your keyboard to load the setup information for this customer.

On the Customer Setup window, in the Stock Sales section of the Catalogs section, click the Master
button.

This will open the Stock Sales Master Catalog window.
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On the New Stock Sales Master Catalog Item window, click the New Item button and enter
XETEX-TSPC for the Item code.

Click the Add Selected Items To Master Catalog button to close the the New Stock Sales Master
Catalog Item window and return to the Stock Sales Master Catalog list.

NOTE: The New Stock Sales Master Catalog Item window is designed to allow adding multiple items
at once to the catalog.  In this case, we are only adding the one XETEX-TSPC item.
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Select the XETEX-TSPC item form the Stock Sales Master Catalog list.

This will open the Stock Sales Catalog Item window for item XETEX-TSPC.

The description and unit of measure defaults from the information in the base item record. Also, the
Notes at the bottom of the window are set to the Long Description from the Item record.  You could
potentially change this information to be displayed differently on the web site.

One thing that you should change is the Small Image. There are two images for each E-Commerce
item. The Small Image should be thumbnail sized so that it can display in a list on a web page. The
Large Image can be much bigger to show more detail of the product if the web user is interested. The
image that you attached to the item record will be the default for both the small and large image on this
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E-Commerce master catalog item. The size of the image for the Large Image should be OK, but you
will want to shrink the Small Image.

Click the Small Image button on the Warehouse Release Catalog Item window. You will see that the
resulting image in the Small Image window will be too big for a thumbnail.

Click the Reduce Size button to bring up the Resize Image window.

For this example, change the Pixel Width to 213 and hit Tab or Enter on your keyboard. Since the
Maintain Aspect Ratio check box is checked, you will see that the Pixel Height adjusts in proportion to
the Width, so when the Width is set to 213, the Height will change to 134.

Click the OK button to complete resizing the image.  You should see the new shrunken image in the
Small Image window.

Click the OK button on the Small Image window to save the new Small Image.
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On the Stock Sales Catalog Item window, notice that Unit Price is 0.00 and Use Item Pricing Structure
is checked.

Since you already entered a multi-level pricing structure on the main Item window, you don't have to
redo it for E-Commerce.  The Use Item Pricing Structure check box will use the Price Information from
the item rather than the Unit Price field on the Stock Sales Catalog Item window if the check box is
checked.

To give XETEX the option of mailing the post cards themselves or having you mail them, click the
Options check box on the Stock Sales Catalog Item window.

This will open the Item Options window.

For the Option Name prompt, enter :

Addressing & Mailing 
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and click the Add Option button.

In the Option Value prompt enter:

No

and click the Add Value button to add the first option value.

In the Option Value prompt enter:

Yes

If you are addressing and mailing the postcards for Xetex, you need to cover the cost of postage and
the additional handling that will be involved.  Assuming that postage for each card is $0.27 and you
want to add $0.09 per card for the additional handling, the total additional unit price for addressing and
mailing would be $0.36.

In the Additional Price prompt, enter 0.36 and then click the Add Value button to add the second option
value.

Now that you have the option and the two values, set this option to be required so that the web user
will be required to choose one of the two options.  Right click on the Address & Mailing option and
select Required from the pop-up menu.

Since you want to encourage XETEX to let you do the mailing, right click on the Yes option value and
choose Default Value.
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Your completed Item Options settings should look like this:

Click the OK button on the Item Options window to save the Item Options and return to the Stock
Sales Catalog Item window.  

The web user who orders this item online needs to be able to attach the artwork for the postcards. 
They also need to be able to attach a mailing list if they want you to put addresses on the printed
postcards and mail them.

In the File Attachments section of the Stock Sales Catalog Item window, check the Allow file
attachments check box.
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The web user must submit at least the artwork files before they can order this item.  Also check the
Require file attachment check box.  This will force the web user to attach at least one file to the item
before they will be able to complete the order.

Enter the following text in the Web user file attachment instructions box:

Please attach artwork files for both the front and back of the postcard.  If you want us to do the
addressing and mailing of the postcards, also attach your mailing list.

The completed Stock Sales Catalog Item window should look like this:
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Click the OK button on the Stock Sales Catalog Item window to save the settings for this item.

Close the Stock Sales Master Catalog window to return to the Customer Setup window.

Below the Master button in the Stock Sales section, you will see a button labeled User.

Click the User button in the Stock Sales section to bring up the Stock Sales User Catalog window.
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The Master catalog is a list of items that are configured for a customer that can be used in a User
catalog. Web users are assigned to particular User catalogs to define the products that the web user is
allowed to order. User catalogs are often a subset of a Master catalog, but it is possible to assign all
items in a Master catalog to a User catalog. If your customer is a large company with multiple divisions
that will be ordering from you, you might set up a different user catalog for each type of person that will
be ordering from that company. In cases like this, you might assign a User catalog to a web user that
only contains items from the master catalog that are relevant to the web user's role in the company.
Another approach would be to create multiple user catalogs with each catalog containing particular
categories of items. Then, for each web user, you would assign all the user catalogs that contain items
of the type that the web user would want to order.

In this example, we just want to create a single User catalog that contains the one item that we have
configured so far in the master catalog.

From the Stock Sales User Catalog menu, choose Commands > New

For the Description on the new user catalog, enter: Xetex Marketing Materials

Click the New Section Description button, enter Postcards for the Section Description, and press the
Tab or Enter key on your keyboard.  So far, the Stock Sales User Catalog window should look like this:



Xebra E-Commerce72

© 2009  Xetex Business Systems, Inc.

On the Stock Sales User Catalog window, click the New Items button to display the Stock Sales
Master Catalog Items list.

Double click the XETEX-TSPC item in the list to select it for the User Catalog.  The User Catalog
should now look like this:
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Close the Stock Sales User Catalog window to return to the Customer Setup window.

Now that you have a user catalog, you need to link it to a web user.  On the Customer Setup window,
click the Web Users button to display the Web Users window.

Click the Find icon on the toolbar.

On the Find Web User window, enter fhickey for the User Name.
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Click the Search button on the Find Web User window and double click the fhickey record in the
Search Results list to load the record.
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If you followed along in the last section, Adding A Warehouse Catalog Item, you should see Xetex
Warehouse Items in the Catalog List already.  We need to add another catalog for the Stock Sales
item that we just configured.

On the Web Users window, click the Add Catalog button.  This will open the Web User Catalog
window.
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On the Web User Catalog, click the binoculars to the right of the Catalog ID.  This will open the Find
Code window.

Double click the Xetex Marketing Materials item from the Find Code list to close the Find Code window
and return to the Web User Catalog window.

On the Web User Catalog window, notice that Default Menu Description is checked.  This means that
this catalog would result in a menu caption on the web site that says whatever the default description
for a stock sales catalog type is set to.  By default, this would be simply Catalog Order.  Instead of the
default description, for this example we want the menu caption on the web site to be the same as the
description that we used for the user catalog - Xetex Marketing Materials.

Click the Use Catalog Description For Menu Item option.
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Click the OK button on the Web User Catalog window to complete adding the new catalog to the
Catalogs list for web user fhickey.  The Catalog list on the Web Users window should now look like
this:

Close the Web Users window.

Close the Customer Setup window.

On the main Xebra E-Commerce window, click the Refresh Web Site button to send your changes to
the web server.

After the refresh completes, reload your web site in a browser. If you need to log in again use the
fhickey user and password fred. If you don't need to log in again, simply click the Home link on the web
site to load or re-load the Home page.

You should see the new Xetex Marketing Materials menu item.
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On the Home page, click the Xetex Marketing Materials menu item.  This will open the Xetex
Marketing Materials catalog page.
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On the Xetex Marketing Materials page, click the thumbnail image of the postcards or the item
description to see the large image of the item in a separate pop-up browser window.

Close the large image browser window to return to the Xetex Marketing Materials catalog page.

Click the More Detail link in the item section for the postcard.

The More Detail links opens a browser pop-up window that displays the additional information that you
entered in the Long Description for the item.
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Close the XETEX-TSPC Details pop-up window to return to the Xetex Marketing Materials catalog
page.

Click the Special Pricing Information link in the item section for the Trade Show Postcard.

The Special Pricing Information link will open a browser pop-up window that displays the multi-level
pricing structure that you configured on the main item record in the Xebra Client software.

Close the XETEX-TSPC Pricing pop-up window to return to the Xetex Marketing Materials catalog
page.

Notice that the Addressing & Mailing option is a drop down list and it has defaulted to Yes with an
additional price of 0.36 as you specified in the Item Options for this stock catalog item.  If you click the
drop down arrow, you can see the No option, but for this example leave the option set to Yes.
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Set the Quantity to 837.

Click the Add to Cart button to add the item to the shopping cart.

This will load the Shopping Cart page.
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Notice that the Unit Price is showing $0.695.  This is calculated when the item is added to the cart
based on the quantity ordered, the multi-level pricing record, and the additional charge option
selection.  According to the pricing structure, quantities over 800 but less than 1000 should have
resulted in a per card price of $0.335.  If you add $0.335 to 0.36 you get $0.695.

Notice that the text you entered for the Web user file attachment instructions on the Stock Sales
Catalog Item window is showing at the bottom of the item section in the Shopping Cart page. Below
the instructions is an Add Attachment button.
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NOTE: If you are following along, you should download the following files from xebra.com and
save them to a known location on your computer.  This way, you will have the files available so
that you can test uploading them to your web site:
http://www.xebra.com/Artwork/ChiPostcard.psd
http://www.xebra.com/Artwork/ChiPostcardBack.psd
http://www.xebra.com/Artwork/ChiPostcard.pdf
http://www.xebra.com/Artwork/ChiPostcardBack.pdf
http://www.xebra.com/Artwork/ChiPostcardMailingList.xls

Click the Add Attachment button on the Catalog Order Section of the Shopping Cart Web Page.

Click the Browse button and select the file, ChiPostcard.psd from the browser specific file dialog.

Then, click the Attach button to begin uploading the file from your local computer to your web site.  If
the upload takes more than several seconds, you will see an upload complete percentage as the file
uploads.  Once the upload completes, the attachment section should look like this:

http://www.xebra.com/Artwork/ChiPostcard.psd
http://www.xebra.com/Artwork/ChiPostcardBack.psd
http://www.xebra.com/Artwork/ChiPostcard.pdf
http://www.xebra.com/Artwork/ChiPostcardBack.pdf
http://www.xebra.com/Artwork/ChiPostcardMailingList.xls
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Repeat the Add Attachment procedure for this item and add the four other files that should be
submitted with this order:

ChiPostcardBack.psd
ChiPostcard.pdf
ChiPostcardBack.pdf
ChiPostcardMailingList.xls

Once you finishing uploading the files to your web site, the Shopping Cart page should look like this:
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Notice the Download button to the right of each file attachment, if for some reason you needed to
download the file back to your local computer from the web site, you could press the Download button.

The View button will download the file and attempt to open it in the appropriate program if it is available
on your computer.  To try this out, click the View button to the right of ChiPostcard.pdf.  You should
see the following PDF after the download from the web site completes.
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Close the PDF.

A delete button is also available to the right of each file attachment so that you can remove an
attachment if you got the wrong file by mistake.  Unless you made a mistake, you don't have to Delete
anything at this time.

Click the Complete Order button on the Shopping Cart page.
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This will load the final Checkout page.  Enter the following information on the Checkout Page:

PO Number: Fred

Special Instructions: I submitted both Photoshop and PDF versions of the artwork files just in case.
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Click the Continue button to complete checkout and load the Order Confirmation page.
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The Order Confirmation page displays all the information entered on the order, including a list of the
file attachment names and sizes.  

Notice that in the image that shows the Order Confirmation page, Sales Tax was calculated as $34.90.
 If the tax location code that you used for your demo XETEX customer was not configured the same,
the Sales Tax and Total that you see may differ.

Now that you've placed the order on the web site, go back to your Xebra Client and go to the main E-
Commerce window.
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Notice that the Unprocessed Activity From Web Site is still showing zero orders for each type.  (If you
don't see zero orders on your Xebra E-Commerce window, you must have Real Time processing
already setup.)

Unless you have Real Time processing enabled, you have to click the Refresh Web Site button to
receive orders from your web server into your Xebra database.  For now, just click the Refresh Web
Site button to receive the order.  After the refresh completes, the Stock Sales total order count will
change to 1 and the Process Stock Orders button will become enabled.

Click the Process Stock Orders button to open the Process Stock Sales window.
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The Process Stock Sales window shows the information that the web user submitted with the order on
the web site.  Notice that the Attachments column of the item list for the order has the number 5 in it. 
This means that five files are attached to this item.  To view the file attachments, double click the
XETEX-TSPC item in the list to open the E-Commerce Stock Sales Item Detail window.

Double click the ChiPostcardMailingList.xls file in the list to open the mailing list file attachment in
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Excel.

For this example, the Excel file contains dummy data rather than real addresses.  Close the Excel file
to return to the E-Commerce Stock Sales Item Detail window.  If you right click on any of the files in the
list, you will see a pop-up menu with two options: Open and Save.

Open would open the file just as if you double clicked it.  The Save option would present that standard
Windows File Save dialog so that you could save the file to a place on your local computer.  On E-
Commerce orders, you are not permitted to delete file attachments or add to the file attachment list. 
The E-Commerce order is meant to be a permanent record of the order as it came into Xebra from the
web user.
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Close the E-Commerce Stock Sales Item Detail window.

On the Process Stock Sales window, click the Process button.

This will open the Create Job - Stock Sales window.

Notice the Ordering Instructions reminder in the list.  This comes from the Ordering Instructions that
you entered on the main item record.  Also notice that the Vendor for all line items has defaulted to
TESTDIGI.  This is because you entered Suggested Vendor 1 as TESTDIGI on the Item record.

You don't have to change anything on the Create Job - Stock Sales window.  Click the Create Job
button to open the Create Job Dialog.

If you are using automatic job numbers, the Job Number will default to the next available job number in
your system.  For this example, change the job number to TESTSS instead so that it will be easier to
find the job and delete it when you're done testing.

The Continue E-Commerce button would create the job and then return you to E-Commerce.  For this
example, click the Load Job button to create the job and switch to Order Entry to view the job.
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Notice that the Special Instructions check box in the center of the Xebra Order Entry window is
checked.
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Click the Special Instructions check box to open the Special Instructions window for the job.

The Special Instructions have the Special Instructions that the web user entered on the web site's
Checkout page as well as the Sales Tax that was calculated on the web site for the order.

Close the Special Instructions window.

On the Xebra Order Entry window, double click the XETEX-TSPC item on the line item list to open the
Line Item window.
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Notice that the File Attachments check box is checked at the lower left corner of the Line Item window.

Click the File Attachments check box to open the File Attachments window.
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This is a list of the artwork files and mailing list file that the web user submitted with the order on the
web site.

You are going to want to send the Photoshop (.psd) files to Test Digital Printing Co. with the purchase
order to have these postcards printed.

Double click ChiPostcard.psd in the File Attachments list to open the File Attachment window.

You could click Open to view the attachment, Save To Disk to save a copy of the .psd file to your local
computer, or you could Delete the attachment from the line item.

All you really need to do is check the Purchase Order check box in the Attach to emails of the following
document types section.
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Click OK to save the email option changes for the ChiPostcard.psd attachment and close the File
Attachment window.

Double click the ChiPostcardBack.psd file in the File Attachments list and set the Purchase Order
option for this file as well.

The two .psd files are the only ones that you need to attach to the purchase order to Test Digital
Printing Co.  They don't need the .png versions that the web user sent and they don't need the .xls
mailing list either because you are going to do the mailing, not Test Digital Printing Co.

After you are done setting the Purchase Order email option for the two .psd files, return to the Line
Item window.

Notice that the Long description and instructions check box is checked on the Line Item window.

Click the Long description and instructions check box to open the Long Description And Instructions
window.
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When you process an E-Commerce Stock Sales item with item options, the item options are appended
to all description and instruction types on the Long Description And Instructions window.  In this case,
the Addressing & Mailing: Yes option doesn't apply to Vendor Instructions because the vendor who will
be receiving the purchase order to print the post cards won't be doing the mailing.  Also, the
Warehouse Instructions are not needed at all for this item because the item is not coming from a
warehouse.  

Remove the Addressing & Mailing: Yes line from both the Vendor Instructions and the Warehouse
Instructions.  The resulting Long Description And Instructions window should look like this.
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Click the OK button to save the modified Long Description And Instructions and close the window.

When you prepare the purchase order to have the postcards printed at Test Digital Printing Co., you
want to specify that the cards should ship back to you instead of to your XETEX customer.  To
accomplish this, you need to enter an alternate address on this line item record.

Click the Alternate Address check box on the Line Item window.

This will open the Alternate Address window.
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The printed cards should ship back to you, so you should enter your address information in the
Alternate Address window.  You might have a Vendor record entered for your in house production or
services.  In this case, you could choose the Copy From > Vendor button to quickly fill in the Alternate
Address window.

Once you have entered your address information into the Alternate Address window, click OK to save
and close the Alternate Address window.

Another problem with the way that this order came over from the web site is that printing of the
postcards, postage, and handling are all lumped together into this one line item with a total unit price of
0.695.  It would be better to split this line item into 3 parts.  The current line item will be the line item
that represents the printing of the post cards.  

Change the Unit Price from 0.695 to 0.335.  0.335 represents the price of the actual post cards based
on the pricing that you entered on the Item record.

Next, you need to add an additional charge for the postage.

Close the Line Item window.

From the Xebra Order Entry window, choose Commands > Additional Charge from the menu.



Xebra E-Commerce102

© 2009  Xetex Business Systems, Inc.

This brings up the Additional Charge window.

NOTE: The following procedure adds another item to the database for direct mail postage.  If you
already have a product for direct mail postage, you can just read through this procedure but use your
existing product code for postage instead of creating a new one.  If you don't already have a product
code for postage, you might want to keep the new postage item in your Xebra database after you
create it through the following steps.

For the Item, enter POSTAGE and hit the Tab or Enter key on your keyboard.  If you don't have a
POSTAGE item record yet, you will see the following message.
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If you want to create the new record, answer Yes to create a new item record.

On the Item record, you can set the first Description line to Direct Mail Postage.

Enter PST for the Product Category code on the new item record and hit Tab or Enter on your
keyboard. (If you already have a product category for postage, you can use that code instead)

In this example, the PST record doesn't exist so you would get another Invalid Code message box
asking you if you want to create a new product category record.

If you want to create the new record, answer Yes to create a new product category.

On the Product Category window, enter Postage for the Category Description.

For the Alternate GL Sales Reference and Alternate GL Purchase Reference, you should pick a GL
code that is appropriate for postage.  This example uses code 5510 but in your chart of accounts, the
best code might be something else.  If you are creating this record and are thinking about keeping it,
you might want to consult with your bookkeeper or accountant if you aren't sure which code to use.

Check the Exclude from sales check box on the Product Category window.  This will prevent postage
line items from affecting sales rep commissions and other sales reports.

The Postage Product Category record should look something like this.
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Close the Product Category window to return to the main Item window.

So far, your Item record for postage should look something like this.

The only other thing you really need to do is set the taxability for your postage item.

Click the Tax check box near the bottom left of the Item window to open the Tax window.
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Click the Tax exempt product check box.  You also need to enter a Tax exempt reason.

Enter PST for the Tax exempt reason and hit the Tab key or Enter key on your keyboard.  (If you
already have a tax exempt reason suitable for postage in your system, you can use that code instead).

If you don't have a PST tax exempt reason record, you will get the following message.

If you want to create the new Tax Exempt Reason, answer Yes to open the Tax Exempt Reason
window and enter Postage for the Description.

Close the Tax Exempt Reason window to return to the Tax window which should now look like this.
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Click the OK button to save your changes and close the Tax window.

You completed POSTAGE item should look something like this.

Close the Item window to return to the Additional Charge window.  When you Tab off of the Item
prompt, the Description and Product category should be pulled from the postage Item record.  If you
have an item record pre-configured for the future, you will save the steps just described to setup the
postage item, postage product category, and postage tax exempt reason.

So far, your Additional Charge window should look like this.
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The Additional Charge window expects Cost and Price to be entered as lot values.  For this postage,
the lot price would be 837 x $0.27 which would be $225.99.

Enter 225.99 for the the Cost/Lt and Price/Lt.

Your completed Additional Charge window should look like this.

Click the OK button to complete adding the separate postage charge to the order.

The job should now have both the XETEX-TSPC item for the postcards, and the POSTAGE item for
the postage.
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Adding an additional charge to a job results in adding a line item to the job just like any other line item. 
The difference between Xebra Order Entry > Commands > Additional Charge and Xebra Order Entry >
Commands > Add Line Item is that the Additional Charge method is less complex and the Add Line
Item method gives you more options.

The next step for processing this order is to add the handling charge.  For this example, use the Add
Line Item method to add the handling charge.

From the Xebra Order Entry window, choose Commands > Add Line Item from the menu.

 This will bring up the New Line Item Type window.
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The item creation method defaults to Item code.  Normally, you might want to have an item code that
represents a service that you provide for addressing direct mail and preparing it for the post office.

For this example, choose the Without item code option and click the OK button on the New Line Item
Type window to open the Item Data window.

For the Description 1 field enter: Addressing & Mailing

There are other optional fields on the Item Data window that you don't need to fill in for this example. 
Click the OK button on the Item Data window to move on to the Vendor/Scheduling Information
window.
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If you really are a service provider for preparing direct mail, you should probably have a vendor code
that represents your company.  If you do, you can use that code.  For this example, we are just going
to leave everything on the Vendor/Scheduling Information window blank.

Click OK on the Vendor/Scheduling Information window to move on to the Line Item Quantities
window.

Enter the following information on the Line Item Quantities window:

Sell Quantity Ordered: 837
Sell Unit of Measure: EA
Buy Quantity Ordered: 837
Buy Unit of Measure: EA
Unit Price: 0.09

The resulting Line Item Quantities window should look like this:

Notice that the Unit Cost is 0.00 in the image above.  The cost is something that you might want to
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enter in a real world situation to represent the estimated cost of labor for preparing this mailing.  For
this example, we simplified and let the Unit Cost be zero.

Click OK to complete the creation of the Addressing & Mailing line item.  The completed Line Item for
Addressing & Mailing should look something like this.

Close the Line Item window to return to the Xebra Order Entry window.  You should now have 3
separate line items for this job.

The 3 line items at this point are unrelated.  To Xebra, these are 3 separate products.  You can
optionally create a relationship between these items.  Assuming that XETEX-TSPC is your main item
and the POSTAGE and Addressing & Mailing are related to this main item, right click on the
POSTAGE item and select Add To Group from the pop-up menu.
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This will open the Add Line Item To Group window.

On the Add Line Item To Group window, double click the XETEX-TSPC item to link POSTAGE to this
main item for the postcards.

On the line item list of the Xebra Order Entry window, you should now see that the POSTAGE item is
indented slightly and the text is not bold anymore like other master items on this job.  POSTAGE is
now a child of the main XETEX-TSPC item.

Right click the Addressing & Mailing item and choose Add To Group from the pop-up menu to make
this item a child of the XETEX-TSPC item as well.

When you are done grouping the line items on the TESTSS job, the Xebra Order Entry window should
look like this.
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To send the purchase order and artwork to Test Digital Printing Co., choose Actions > Prepare Vendor
Purchase Order from the Xebra Order Entry menu.

This will open the Prepare Vendor Purchase Order window.
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On the Prepare Vendor Purchase Order window, note that the Vendor defaulted to TESTDIGI and the
only item selected for the purchase order is the XETEX-TSPC item.  This is because the
XETEX-TSPC line item is the only one set with the TESTDIGI Buy From code.

To generate the purchase order, choose Commands > Create Purchase Order from the Prepare
Vendor Purchase Order menu.

This will open the Purchase Order Editor window and show a preview of the purchase order document.
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The Ship To area on the purchase order should show your company name and address that you
entered into the Alternate Address of the line item record for the XETEX-TSPC item.

From the Purchase Order Editor menu, choose Options > Additional Instructions After Last Line.

For the Addtional Instructions, enter the following text:

Please see the attached artwork files in Photoshop format for the front and back of the postcard:
ChiPostcard.psd
ChiPostcardBack.psd
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On the Purchase Order Edit toolbar, click the Save button to finalize the purchase order.

The completed Purchase Order document will be displayed in Xebra Print Preview.
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To email the purchase order to the vendor, click the email button from the Xebra Print Preview toolbar.
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The email should open in the default email client for your computer.  The following image shows the
email in Windows Mail.

Notice that the artwork files are attached as you specified on the line item File Attachments.  The Job
TESTSS.pdf file is a PDF version of the purchase order document.  From this point, you could alter the
text of the email to again describe the file attachments and what they are and you could send the
email.  Since Test Digital Printing Co. isn't real and this isn't a real order, don't try to send the email.

Close the email without sending.

Close the Xebra Print Preview window.

Close the Prepare Vendor Purchase Order window.

Since the TESTSS job is just an example, it would be good to remove it from your live system.  Click
the red X on the Xebra Order Entry toolbar to remove the job.
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NOTE:  If the red X is disabled, you will need to find a Xebra operator in your company with the correct
security privileges to delete the job.

3.1.3 Adding A Stationery Item

The Xebra E-Commerce Stationery catalog type is for any items for which the web user will need to
specify text to be imprinted on the item.  A common example of an item for which the Stationery
catalog is suitable is a business card where the web user might want to specify the name, address,
phone, email, etc. to be printed on the cards.  You might also use the Stationery catalog for items such
as personalized pens, embroidered or silk screened shirts, direct mail pieces, etc.  Whenever you want
the web user to be able to specify text to be imprinted on an item and provide the web user with a
proof image of the imprinted item, the Stationery catalog type is the one to use.

For this example, we are going to use a Xetex business card for the item to add to the stationery
catalog.  Let's assume that Xetex sends you the artwork file in Adobe InDesign CS3 format.

If you want to follow along with this example and you can work with .indd files, you can download the
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file from the following link:
http://www.xebra.com/Artwork/XetexBusCard.indd

If you can't work with this .indd file, don't worry.  Just read along.  You will be provided with all the files
that are absolutely necessary to work through this example.  Even if you don't use Adobe InDesign
CS3, you might be able to apply some of the concepts, shown in the InDesign examples, to your own
graphics tools.

The first step to setting up this item is to create the main Item record in Xebra.

From the Xebra Order Entry window, choose View > Item from the menu. 

From the Item window menu, choose Commands > New

On the New Code window, enter XETEX-BC for the new Item code.

http://www.xebra.com/Artwork/XetexBusCard.indd
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Click the OK button on the New Code window to create the new Item record.

On the Item window, enter the following information:

Description 1: Xetex Business Cards
Description 2: Digital Print
Packed: 500 EA Per: BX
Sell Unit of Measure: BX
Buy Unit of Measure: BX
Suggested Vendor 1: TESTDIGI

Note: In the Adding A Stock Sales Item section, we created the TESTDIGI vendor code.  If you did not
create the TESTDIGI vendor code, but you want to follow along with this section, please refer to the 
Adding A Stock Sales Item  section for instructions to create the TESTDIGI vendor code. 

So far, the Item window should look like this.

51
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It would be good to add an image that represents the business card.  If you can open the
XetexBusCard.indd file in Adobe InDesign CS3, choose File > Export from the menu.

In the Export file save dialog, choose JPEG for the Save as type and specify a location on your
computer to save the file.
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Click the Save button to open the Export JPEG window. In the Export JPEG window, set the following
options:

Export: All
Quality: Maximum
Format Method: Baseline
Resolution (ppi): 300
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The Maximum quality setting minimizes the degrading effects of JPEG compression, but it doesn't
completely eliminate unsightly artifacts.  It would be better to save the file in a non-lossy format, such
as PNG, but it doesn't seem that Adobe InDesign has that option.  An alternative would be to export
the file to a PDF, then open the PDF file in Photoshop, and then save the file as a PNG.  We will
explore this alternative later in this example, but for now, we will stick with the JPEG option.  

Click the Export button on the Export JPEG dialog to complete saving the .jpg file.

If you weren't able to Export the JPEG from Adobe InDesign, you can download it from this link:
http://www.xebra.com/Artwork/XetexBusCard.jpg

Back on the Xebra Item window, click the Image check box.

On the Image window, click the Add button.

In the standard Windows File Open dialog, open the file XetexBusCard.jpg.  You should end up with a
fairly high resolution image of the business card in the Image window.

http://www.xebra.com/Artwork/XetexBusCard.jpg
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Click Ok on the Image window to save the Image and return to the Item window.  

Click the Long description and instructions check box and enter the following for both the Long
Description and Vendor Instructions:

BOXES OF 500 BUSINESS CARDS
12PT. C-1-S GLOSS COVER WHITE

Remember that you can use CTRL+C to copy the text and CTRL+V to paste the text into the multiple
instructions fields.
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Click the OK button to save the descriptions and close the Long Description And Instructions window.

For this example, assume that you have an agreement with Test Digital Printing Co. that the cost of a
box of 500 cards will be $15.00 regardless of the quantity of boxes.  

On the Item window, click the Price Information check box.

Answer No to the question, "Would you like to create a multi-level pricing structure?"

Leave the Price Per Unit blank and enter a Cost Per Unit of 15.00.

Click OK to save the Single Level Pricing information.

The completed item record should look like this.
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Now that you have the Item record, you are ready to create the actual E-Commerce Stationery catalog
item.  

Close the Item window and use the Go menu to go to the main Xebra E-Commerce window. 

On the Xebra E-Commerce window, choose Actions > Customer Setup.

On the Customer Setup window, enter XETEX for the Master Customer code and hit Tab or Enter on
your keyboard to load the setup information for this customer.

On the Customer Setup window, in the Stationery section of the Catalogs section, click the Master
button.

This will open the Stationery Master Catalog window.
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On the Stationery Master Catalog window, click the New Item button.  This will bring up the New
Stationery Master Catalog Item window.

For the Item # enter XETEX-BC and then press the Add Selected Items To Master Catalog button.
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Since we only added one new item to the Master Catalog, the Stationery Catalog Item window comes
right up.
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There are two images for each E-Commerce item. The Small Image should be thumbnail sized so that
it can display in a list on a web page. The Large Image can be much bigger to show more detail of the
product if the web user is interested. The image that you attached to the item record for XETEX-BC
will be the default for both the small and large image on this E-Commerce master catalog item. The
size of the image for the Large Image should be OK, but you will want to shrink the Small Image.

Click the Small Image button on the Warehouse Release Catalog Item window. You will see that the
resulting image in the Small Image window will be too big for a thumbnail.
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Click the Reduce Size button to bring up the Resize Image window.

For this example, change the Pixel Width to 213 and hit Tab or Enter on your keyboard. Since the
Maintain Aspect Ratio check box is checked, you will see that the Pixel Height adjusts in proportion to
the Width, so when the Width is set to 213, the Height will change to 121.

Click the OK button to complete resizing the image. You should see the new shrunken image in the
Small Image window.

Click the OK button on the Small Image window to save the new Small Image.

On the Stationery Catalog Item window, notice that the Packing Description defaulted to 500 EA Per
BX.  This information came from the XETEX-BC item record that you created.  If you want pricing to
show on the web site for this item, you need to add quantity restrictions with pricing.

Click the Add Quantity Restriction button.
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On the Internet Quantity Restriction window, enter the following information:

Quantity: 1
UOM: BX
Price: 39.99

Click the OK button on the Internet Quantity Restriction window to save this first quantity option.

On the Stationery Catalog Item window, click the Add Quantity Restriction button again to add another
quantity/price option.  This time, use the following information on the Internet Quantity Restrction
window.

Quantity: 2
UOM: BX
Price: 74.99

The Price field on the quantity restriction is not a unit price.  It is the extended price for the item at the
specified quantity.

Enter another quantity restriction with the following information:

Quantity: 3
UOM: BX
Price: 99.99

After you are done entering the three quantity restrictions, the Quantity Restrictions list on the
Stationery Catalog Item window should look like this:
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Stationery items are meant to capture information from the web user to be imprinted on the item.  To
accomplish this, you need to setup a template that specifies what information you are going to ask the
web user to enter and where to print the information that the web user enters.

To create the template for this item, click the Template button on the Stationery Catalog Item window.

There are currently two options for creating a new template as shown in the Template Creation Method
window.

If you had a similar template that you used for another item, you might start with Import Template File
to bring in a template that you exported from another item.  You might also use Import Template File if
somebody at Xetex creates a template file for you.

In this case, we want to create a new template from scratch, so we will leave the Choose Background
Image option checked.

Before we go further with creating the Template in Xebra, we need to gather some information and the
background image.

If you can open the XetexBusCard.indd file in Adobe InDesign CS3, start by opening the file.
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InDesign, seems to default to showing measurements in picas.  Since the Xebra template editor works
with inches, the first thing you should do in InDesign is change the preference so that it will work with
inches instead of picas.

From the InDesign CS3 Edit menu, choose Preferences > Units & Increments...

 

This will open the Preferences window for Units & Increments.
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In the Ruler Units section of the Preferences window, change the Horizontal value to Inches and
change the Vertical value to Inches.

Click the OK button on the Preferences window to save the changes and close the window.

Now, just by looking at the rulers in InDesign, you should be able to see that this business card is the
standard 3 1/2 Inches wide by 2 Inches high.



Xebra E-Commerce136

© 2009  Xetex Business Systems, Inc.

One of the things that you will need to know to setup the template in Xebra is the size of the artwork in
inches.  We now know that the size for this artwork is 3.5" x 2".

The next step is to determine what part of this card will be variable text that the web user will be able to
enter.  One part of this card that will be variable is the person's first name, which in the artwork is
specified as Dave.

Make sure you select the dark arrow in the InDesign toolbar.

With the Selection Tool selected, click on the text, Dave, to select that box.
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When you select the Dave text box in InDesign, notice that the coordinates of that box are available in
the upper left hand corner of the InDesign window.

To the left of the coordinate values is a series of 9 little boxes, 8 white ones and one black one.  The
black box sets the origin for the coordinate values.  In the picture above, the origin is set to be the
center of the page.  In Xebra, the origin is always the top left, so click the top left box to set the origin
to match Xebra.

After you set the origin of the coordinates to be the top left, look at the positioning values for the Dave
text box.

By looking at the X value, we know that the left of this text box is at 0.1181 inches.
By looking at the W value, we know that the width of this text box is 1.2396 inches.
By looking at the Y value, we know that the top of this text box is at 1.1736 inches.
By looking at the H value, we know that the height of this text box is 0.1799 inches.

It will be helpful to know these values when you create the template in Xebra.

Another thing we need to know about this text box is what font was used.  From the InDesign Window
menu, choose Type & Tables > Character.



Xebra E-Commerce138

© 2009  Xetex Business Systems, Inc.

This will bring up a window that will show you information about the font.

We can see from this character information that the font was Arial Black 14.5 pt.

Also, notice that this box has a character spacing adjustment specified.
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Tracking is set to 325.

One other thing we need to know is how InDesign is setting the baseline for the first line of text within
this text frame.  Right click on the Dave text frame and, from the pop-up menu, choose Text Frame
Options...

This will open the Text Frame Options window.
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Click the Baseline Options tab on the Text Frame Options window.

At the top of the Baseline Options tab, you can see that the First Baseline is set to a Fixed Offset with
a value of 0.17 inches.

Click the Cancel button to close the Text Frame Options window.

One more thing that you should note about the Dave text frame is that the text is centered horizontally
within the box and the text is black.

Now that we know the positioning of this box and the font information, delete the box from the
InDesign artwork.  This box will be variable on the Xebra template for the item and the web user will
enter the text to be printed.  We don't want the text "Dave" to be part of the background for this
template.

With the Dave text frame selected, press the Delete key on your keyboard to remove the box.  The
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artwork in InDesign should now look like this:

The last name will also be text that the web user will specify.  In the artwork, the text box for the last
name is Hartranft.  Make sure the dark selection arrow is selected in InDesign and click on Hartranft to
select that text frame.
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Note the coordinates and font information:
Left=0.1181 inches
Width=1.2396 inches
Top=1.4028 inches
Height=0.1181 inches
Font=Arial Black 9.5 pt
Tracking=0

Right click on the Hartranft text frame, choose Text Frame Options... from the pop-up menu, and click
on the Baseline Options tab.  Notice that the First Baseline Offset is set to Ascent, which means that
the top of the highest letters in the font text should touch or be close to the top of the text frame.
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Close the Text Frame Options window.

With the Hartranft text box selected, press the Delete key on your keyboard to remove it from the
background artwork.

Another field that will be variable on this card is the email address.  Make sure the dark selection arrow
is still selected in InDesign and click on dave@xebra.com to select that text box.

Note the coordinates and font information:
Left=1.97 inches
Width=0.85 inches
Top=1.3192 inches
Height=0.1143 inches
Font=Arial Bold 6.5 pt
Tracking=0

If you check the text frame options for the dave@xebra.com text frame, you will see that the First
Baseline Offset for this box is set to Ascent.

With the dave@xebra.com text box selected, press the Delete key on your keyboard to remove it from
the background artwork.

The only other field that will be variable on this card is the telephone extension.  Make sure the dark
selection arrow is still selected in InDesign and click on the 21 to select that text box.
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Note the coordinates and font information:
Left=1.524 inches
Width=0.1004 inches
Top=1.6736 inches
Height=0.1143 inches
Font=Arial Bold 6.5 pt
Tracking=0

If you check the text frame options for the 21 text frame, you will see that the First Baseline Offset for
this box is set to Ascent.

With the 21 text box selected, press the Delete key on your keyboard to remove it from the
background artwork.

Although we've covered the four fields that will have variable text, there are two more text boxes on
this InDesign layout that we need to look at.  The line starting with 800-356-2772 and ending with Fax:
610-898-1564 should be left justified.  The space between the variable telephone extension and the
fax number should remain constant, so the fax number (including the bullet before the fax number) will
have to shift depending on the width of the telephone extension that the web user enters.  Also, we
want the telephone extension field to be optional.  If the web user doesn't specify an extension, the text
"ext." should not show in the artwork either and the fax number should shift left to fill in the gap.

Make sure the dark selection arrow is still selected in InDesign and click on the ext. box.
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Note the coordinates and font information:
Left=1.345 inches
Width=0.1556 inches
Top=1.6736 inches
Height=0.1143 inches
Font=Arial Bold 6.5 pt
Tracking=0

If you check the text frame options for the ext. text frame, you will see that the First Baseline Offset for
this box is set to Ascent.

With the ext. text box selected, press the Delete key on your keyboard to remove it from the
background artwork.

Make sure the dark selection arrow is still selected in InDesign and click on the Fax: 610-898-1564
box.
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Note the coordinates and font information:
Left=1.647 inches
Width=0.9 inches
Top=1.6736 inches
Height=0.1143 inches
Font=Arial Bold 6.5 pt
Tracking=0

If you check the text frame options for the fax text frame, you will see that the First Baseline Offset for
this box is set to Ascent.

Another thing that you need is the actual text.  This won't be variable information that the web user
enters.  You will have to enter this text in this fax box into the Xebra template.

Double click the text in the fax text box and then highlight all of the text in the box, including the bullet.

With the text in the fax box highlighted, hold the CTRL key on your keyboard and then press the C key
on your keyboard to copy the text to the Windows clipboard.
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From the Windows Start menu, choose Run.

In the Windows Run dialog, enter notepad as the program to Open and click the OK button.

Once Notepad opens, hold the CTRL key on your keyboard and then press the V key to paste the text
of the Fax information text box into Notepad.

Click the minimize button on the Notepad window to get it out of your way without closing it.
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Now that you have all the information that you need from the fax text box, you can delete it from the
InDesign background artwork.

Make sure that you switch to the dark selection arrow in InDesign and then make sure that the fax
information text box is selected.  Then, press the Delete key on your keyboard to remove the fax
information text box.

The resulting artwork in InDesign with only the background art should look like this:

Xebra can't currently work with this InDesign artwork directly.  The best format for Xebra to use is
PNG, but InDesign doesn't seem to be able to create PNG files.  This requires an intermediary step.

From the InDesign File menu, choose Export...
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In the Export dialog, choose Adobe PDF as the Save as type.
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Click the Save button on the Export dialog to open the Export Adobe PDF dialog.
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At the top of the Export Adobe PDF dialog, set the Adobe PDF Preset to [High Quality Print]

Click the Compression menu item on the Export ADobe PDF dialog.

On the Compression setting screen, select Do Not Downsample for all image types.  Also, change
Compression to None for all image types.  You are trying to get the highest quality image possible, so
you don't want lossy JPEG compression or downsampling of raster images.  The Export Adobe PDF
compression settings should look like this.
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Click the Export button on the Export Adobe PDF window to complete creation of the PDF file.

If you don't have InDesign and you want to see the PDF file, you can download it from the following
link:
http://www.xebra.com/Artwork/XetexBusCard.pdf

Now that you have the PDF file, you can close InDesign.  If you want to save the InDesign background
art, you should save it to a file with a different name than the original, such as XetexBusCard-
background.indd

For Xebra, we still need to convert the pdf to a PNG file.  One way of doing this is with Adobe
Photoshop.  If you have Photoshop, open the XetexBusCard.pdf file with Photoshop.

If you open the XetexBusCard.pdf file in Adobe Photoshop CS3, you will see the Import PDF dialog.

http://www.xebra.com/Artwork/XetexBusCard.pdf
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In the Page Options section of the Import PDF dialog, select Crop To: Media Box.  This should make
the Image size display correctly at 3.5 inches by 2 inches.  Set the Resolution to 600 and the color
Mode to RGB Color with a Bit Depth of 8 bit, then click the OK button to convert the PDF file to a
Photoshop image.

Choose Layer > Flatten Image from the menu.
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Then, choose File > Save As...
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In the Save As dialog, choose PNG as the Format and save the XetexBusCard.png file to your local
computer.
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In the PNG Options dialog, select None and click the OK button.

Now that you have the background PNG file, you can close Photoshop and return to Xebra to continue
creating the E-Commerce Stationery Template.
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If you haven't been able to follow along with the InDesign and Photoshop example, you can download
the background image PNG from the following link:
http://www.xebra.com/Artwork/XetexBusCard.png

Return to Xebra and on the Template Create Method dialog, select Choose Background Image and
then click the OK button.

In the Windows Open dialog, choose the XetexBusCard.png file.

Next you will see the Template Page Properties window.

From the InDesign example, we know that this business card is 3.5" x 2".

In the Template Page Properties dialog, enter 3.5 for the Width (Inches).

When you tab off of the Width prompt, the Height should get set to 2.0 because the template editor
always maintains the proportions of the page size.

Based on the Width and Height in inches and the Width and Height of the background image in pixels,
Xebra calculates the Maximum resolution for this template to be 600 DPI.  

http://www.xebra.com/Artwork/XetexBusCard.png
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You should specify for the Target Print/PDF Resolution (DPI) the highest resolution that you expect a
printer to use to print this item.  You can't specify a higher resolution than the Maximum Resolution.  If
you needed a higher resolution than what displays in the Maximum Resolution (DPI), you would have
to replace the background image with a higher resolution PNG. For this example, use 600 dpi for the
Target DPI.

The Online Proof Image Resolution (DPI) provides you with a way to specify how big the proof image
will be on the web site.  Normal screen resolution is 96 DPI.  Previous versions of Xebra always made
the proof image at 96 DPI.  Since this business card has a small page size and some small fonts, it
would look better and be easier to read online at a slightly bigger size.  Enter 120 for the Online Proof
Image Resolution (DPI).

Your Template Page Properties settings should look like this.

Click the OK button on the Template Page Properties dialog to save the settings and open the new
template in the Template Editor.

Notice that the title bar of the Template Editor shows 100% (1:1).  This means that the template is
going to be displayed at 100% of the Target Print/PDF Resolution that you specified in the Template
Page Properties.  At 600 DPI, this 3.5" x 2" template displays very large at 100%.  You probably will
only be able to see a small part of the template at a time.  

From the Template Editor menu, choose Zoom > 25% of Target Print/PDF Resolution (4:1)
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At the 25% zoom level, you should be able to see the entire template page without scrolling.

So far, the only thing showing in the template is the background.   To add the first variable field to this
template, click the Insert Box button on the toolbar.

Clicking the Insert Box toolbar button will put the Template Editor into insert mode.  As you move the
mouse pointer across the template, you should see that the mouse pointer is now a cross.  Click the
mouse down at approximately the place where the top left corner of the first name field will go and
drag with the mouse still down to create an insertion rectangle about the right size.  It is not important
to get the box positioned correctly at this point.  All you need to do is draw a box somewhere on the
template page.
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When you let go of the mouse button, your new box should appear on the template outlined in blue
with red sizing rectangles.

Double click the new box to open the Box Properties window.
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The Caption field is what the web user will see when they are prompted to enter the variable text for
the box.  For this box, set the Caption to First Name.  The Display Text prompt allows you to enter
sample text to display in the box instead of just showing the Caption.  If you use the Display Text field,
you will see this text in the Template Editor, and the web user will see this text on the image of the
template on the web page that prompts them to enter the variable text.  For this box, enter Dave for
the Display Text.

In the Box positioning section of the Box Properties window, check Lock box to these values.

Since we are going to enter specific coordinates that we got from the InDesign artwork, checking Lock
box to these values will keep the box position locked in to the exact coordinates that we enter for the
box in inches.  The box will no longer be moveable with the mouse or keyboard.  Also, without the
Lock box to these values check box checked, Xebra would adjust any values entered to values that
match a coordinate in pixels at the Target Resolution.  Checking the Lock box to these values check
box will prevent any adjustments from occurring except for values that you enter specifically in the Box
positioning values.

Xebra allows you to either enter a Right coordinate or a Width.  Since InDesign used Width instead of
specifying the right edge of the box, click the Width option button so that you can specify a Width in
Xebra.  The same applies to the box height.  Click the Height option button.  Then, enter the values
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that we got from the InDesign artwork for this box:

Left: 0.1181
Width: 1.2396
Top: 1.1736
Height: 0.1799

Your Box positioning values should now look like this:

We saw that in InDesign, the font used for the first name was Arial Black 14.5 pt.  In the Font section
of the Box Properties window, select Arial Black from the Name drop down list.  

Regular is the only style that is truly available in the Arial Black font.  If you see any other styles for this
font available in other applications, these are pseudo styles that the application is rendering on its own
and not styles that are part of the font.  Xebra currently only supports the styles that are really available
in the font.

Set the Size (pt) of the font to 14.5.  Since this is an odd size, you will have to type in the size manually
rather than select it from the drop down list.

The color of the text in InDesign was black, so you can leave the color set to black.

We saw that in InDesign, Tracking was set to 325 for the first name text frame.  In the Font section of
the Xebra Box Properties dialog, enter 325 for Character spacing.  Xebra uses that same unit of
measure that was used in InDesign, which was Thousandths of an em or in other words, Thousandths
of the size of the font in points.

We saw that in InDesign, the baseline of the text in the first name text frame was set to a fixed value of
0.17 inches.  Click the option button ...equal to a fixed distance.  Then, enter 0.17 in the Fixed baseline
from top of box prompt.

The first name was centered within the box, so click the Center option under Horizontal Alignment.

The Font section of the Box Properties window should now look like this:
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Xebra allows you to specify a background color for variable text.  This background color is meant to
highlight the fields that are variable in the image of the template that is shown to the web user when
they are prompted to enter the text for the variable fields.  For this example, click the Highlight Color
picker...

...and in the Color dialog, select yellow.

Click the OK button on the Color dialog to close it and return to the Box Properties window.  

Your completed Box Properties for the First Name field should look like this:
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Click the OK button on the Box Properties window to save the changes and return to the main
Template Editor window.  Your template should now look like this:

Click the Insert Box button on the toolbar and draw another new box for the Last Name field below the
First Name box.  The size and position doesn't have to be exact since we will enter the position values
in the Box Properties dialog.

Double click the new empty box to set the Box Properties.  Enter the following information, most of
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which came from the original artwork in In Design:

Caption: Last Name
Display Text: Hartranft

Box positioning
Lock box to these values=checked
Left: 0.1181
Width: 1.2396
Top: 1.4028
Height: 0.1181

Font
Name: Arial Black 
Size (pt): 9.5
Character spacing=0
Horizontal Alignment: Center
Set Font baseline distance from top of box...equal to the font ascent - font file outline metrics

Note that there are two options in Xebra for setting the baseline of a font based on the font ascent.  It
turns out that Windows reports a different value for a font's ascent than what is really specified in the
font file.  Windows ascent values are generally higher, which results in a little space between the
highest characters in the box and the top of the box.  Font file ascent values generally result in the
highest characters of the box going all the way up to the top edge of the box with little or no space. 
When you specify that the baseline should be an Offset based on the Ascent in In Design, In Design is
always referring to the ascent value that comes directly from the font file.  In this case, you need to use
the  "equal to the font ascent - font file outline metrics" option in Xebra's Box Properties window.

The yellow Highlight color should default from the previous box that you created.

Click the OK button on the Box Properties to save the settings for the new box and return to the main
Template Editor window.  Your template should now look like this:
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Click the Insert Box button on the toolbar and draw another new box for the email field to the right of
the Email: caption in the template background.  The size and position doesn't have to be exact since
we will enter the position values in the Box Properties dialog.

Double click the new empty box to set the Box Properties.  Enter the following information, most of
which came from the original artwork in In Design:

Caption: E-Mail
Display Text: dave@xebra.com

Box positioning
Lock box to these values=checked
Left: 1.97
Width: 0.85
Top: 1.3192
Height: 0.1143

Font
Name: Arial
Style: Bold
Size (pt): 6.5
Character spacing=0
Horizontal Alignment: Left
Set Font baseline distance from top of box...equal to the font ascent - font file outline metrics

The yellow Highlight color should default from the previous box that you created.

For this example, we will setup this Email address field so that it shows up as a drop down list for the
web user to select from pre-set values.  In the Box type section of the Box Properties dialog, click the
Drop down list option button.
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Click the Add Entry button to open the Add Drop Down List Item window.

In the Text prompt, enter:

dave@xebra.com

then, click the OK button to add this first entry and return to the Box Properties window.

Click Add Entry and add the following additional email addresses to the list:

sales@xebra.com
george@xebra.com
ron@xebra.com
kathy@xebra.com

The completed Box Properties window for this email address variable field should look like this:
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Click the OK button on the Box Properties to save the settings for the new box and return to the main
Template Editor window.  Your template should now look like this:

Click the Insert Box button on the toolbar and draw another new box for the extension number field to
the right of the phone number text in the background image.  The size and position doesn't have to be
exact since we will enter the position values in the Box Properties dialog.

Double click the new empty box to set the Box Properties.  Enter the following information, most of
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which came from the original artwork in In Design:

Caption: Extension
Display Text: 21

Box positioning
Lock box to these values=checked
Left: 1.524
Width: 0.1004
Top: 1.6736
Height: 0.1143

Font
Name: Arial
Style: Bold
Size (pt): 6.5
Character spacing=0
Horizontal Alignment: Left
Set Font baseline distance from top of box...equal to the font ascent - font file outline metrics

The yellow Highlight color should default from the previous box that you created.

Click the OK button on the Box Properties to save the settings for the new box and return to the main
Template Editor window.  Your template should now look like this:

The next box to add is the box with the static "ext." text that should come before the extension number
only if the extension number isn't blank.

Click the Insert Box button on the toolbar and draw another new box between the phone number text
and the extension number box.  The size and position doesn't have to be exact since we will enter the
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position values in the Box Properties dialog.

Double click the new empty box to set the Box Properties.

For the Caption, enter:

ext.

In the Box type section, select the Static text option.  Then, select Extension as the Link to box.

If you specify a Link to box for a Static text box, this means that the static text will not show in the
proof/artwork if the web user doesn't enter any text for the field specified by the Link to box.

Continue entering the following information into the Box Properties window, most of which came from
the original artwork in In Design:

Box positioning
Lock box to these values=checked
Left: 1.345
Width: 0.1556
Top: 1.6736
Height: 0.1143

Font
Name: Arial
Style: Bold
Size (pt): 6.5
Character spacing=0
Horizontal Alignment: Left
Set Font baseline distance from top of box...equal to the font ascent - font file outline metrics

The yellow Highlight color should default from the previous box that you created.

Click the OK button on the Box Properties to save the settings for the new box and return to the main
Template Editor window.  Your template should now look like this:
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The last box to add to this template isn't a variable field and it will always print, but you need to add the
static fax number text in a way that it will shift depending on the length of the telephone extension
number.  The fax number should shift right as the extension number gets longer.  If there is no
extension number, the ext. caption and the number won't show and the fax information should move
left to fill the gap.

Click the Insert Box button on the toolbar and draw another new box for the fax field to the right of the
extension number box.  The size and position doesn't have to be exact since we will enter the position
values in the Box Properties dialog.

Double click the new empty box to set the Box Properties.

Restore the Notepad document and highlight the fax number text including the bullet.  Hold the CTRL
key on your keyboard and press C just once to copy the text into the Windows clipboard.  Then, 
minimize Notepad and click on the Caption prompt on the Box Properties dialog to set focus to it.  Hold
the CTRL key on your keyboard and press V to paste the fax text into the Caption prompt.  The bullet
will show up as a weird character in the Caption prompt but it will display correctly in the main
Template Editor window once you are done setting the Box Properties.

Note: If you didn't have the text for the bullet and fax number text in Notepad, you can enter it
manually.  Hold the Alt key on your keyboard and press the following sequence of numbers on the
number pad of your keyboard: 0, 1, 4, 9.  After you enter the last number in the sequence, release the
Alt key and the strange character that represents the bullet should appear in the Caption prompt. 
Then, enter a space followed by the text:
Fax: 610-898-1564

In the Box type section of the Box Properties window, select the Static text option.
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Leave the Link to box blank because the fax information should print regardless of what the web user
enters in the other fields.

Enter the following information, most of which came from the original artwork in In Design:

Box positioning
Lock box to these values=checked
Left: 1.647
Width: 0.9
Top: 1.6736
Height: 0.1143

Font
Name: Arial
Style: Bold
Size (pt): 6.5
Character spacing=0
Horizontal Alignment: Left
Set Font baseline distance from top of box...equal to the font ascent - font file outline metrics

So far, the Box Properties window should look like this:

Click the OK button to save the settings and return to the main Template Editor window.
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When you return to the Template Editor window, you should see the fax text box is selected.  Hold the
CTRL key on your keyboard and click the extension box that says 21.  You should see that now both
the 21 box and the fax box are selected. Hold the CTRL key on your keyboard and click the ext. box. 
Now, all three boxes should be selected.

Once the three fields are selected, double click the Fax information box to open the Box Properties
window again.  

You will notice that every field on the dialog is highlighted now.  This happens when you open the
properties window with multiple boxes selected at the same time.
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In the Box Movement section of the Box Properties window, click the Horiontal ID prompt and enter 1. 
Then, hit the Tab key on your keyboard.

When you Tab off of anything on the Box Properties form, the attention highlight goes away.  Any field
that doesn't have the attention set will get modified when you click the OK button.  The fields that still
have the attention won't be modified.  This is to prevent changing things that should not be the same
on all of the boxes that are selected.

In this case, we want all three boxes to have the Horizontal ID set to 1.  Giving multiple boxes the
same Horizontal Box Movement ID creates a horizontal movement group.  You can really pick any
number for the ID as long as the number is the same for all boxes in the group.  It's a good idea to use
1 for the ID on the first group.  In this case, we only want one horizontal box movement group, but if we
wanted to have multiple groups, we would use 2 for the next ID to make sure that it is a different ID for
the next group.

When you tab off of the Horizontal Box Movement ID, the Left option is selected automatically.  This is
what we want.  When a horizontal group is left justified, the group is always placed starting with the left
edge of the left most box in the group.  The next box from left to right in the group is placed depending
on the length of the text in the first box.  The left of the second box will be set to the right edge of the
text in the first box, plus the horizontal space between the two boxes in the Template Editor.  Once the
2nd box is placed, the left of the 3rd box will be placed so that the left edge of the 3rd box is equal to
the right edge of the text in the 2nd box, plus the space between the 2nd and 3rd boxes.  The space
between the Extension number box and the fax information box will be maintained when the length of
the text in the Extension number changes.  In this group, if the web user doesn't enter an Extension
number, the ext. box and the Extension box will be removed making the Fax information box the only
box in the group.  If the fax information box is the only box left in the group, it will be aligned to the left
of where the ext. box was in the template before it got removed.
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Click the OK button on the Box Properties window to save the changes to the three boxes in the
horizontal group and return to the main Template Editor window.

Click anywhere on the template page that there isn't a box to remove the selection from the extension
and fax boxes.  So far, your template should look like this:

The final step is to set the order that the web user will be prompted to enter the variable fields.  The
first field that they should enter is the first name, so right click on the box with the text "Dave" in it.  You
should see a red one appear in the lower right hand corner of the box indicating that this is the first
variable field that the web user should enter.

Right click on the box with the last name, Hartranft, to set it to be the 2nd box.

Right click on the box with the email address, dave@xebra.com, to set it to be the 3rd box.

Right click on the box with the extension, 21, to set it to be the 4th box.

Your completed template should look like this.
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Note: In this example, we locked the position of the boxes and we specified the exact size and
positioning of the boxes in the Box Properties window.  This insures that everything is lined up exactly
the way that we want it.  If you create a template without specifying exact size and positioning in the
Box Properties, and instead use the mouse or keyboard to move and size boxes on the template page,
you should always review your template at 100% or 200% and make minor adjustments if necessary. 
At 50% and especially at 25%, you might not see that the position of the boxes isn't quite where you
intended because the re-sampled view doesn't show every pixel.  Movements of the boxes with the
keyboard or mouse are always in increments of pixels at 100% of the Target resolution.

Close the Template Editor and be sure to answer Yes to save your changes.

When you return to the Stationery Catalog Item window, notice that some additional options are
available in the Artwork Attachment Default Options section.

When you process Stationery orders from your web site and create jobs, three attachments will be
added to the line item:
1. The same screen resolution proof that was shown on the web site to the person placing the order.
2. A PDF document that contains only the text boxes of the artwork.
3. A PDF document that contains the background image and the variable text.
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When you generate a purchase order and create an email to send to the printer, you might want to
include some of these attachments on the email.

You would send them the screen resolution proof if you want to give the printer an idea of what the
finished product should look like.

You would send the Text-only PDF version of the artwork if the printer already has the background
artwork or pre-printed masters that only need to be over-printed with the variable text.

You might send the full PDF with background & text if the artwork is going to be printed on a digital
printer and the background image was produced at a sufficient resolution to create a quality print.

By default, Xebra always selects the Screen resolution proof (PNG) option.  Xebra selects the Text-
only PDF option by default if the background image is low resolution.  If the background image is high
resolution, as in this example, Xebra selects the PDF with background & text to be attached to PO
emails.

It is ultimately up to you what you want to send to the vendor so you can change these options at any
time.  For this example, we will keep the default selections for which versions of the imprint artwork to
email to the vendor.

Click the OK button on the Stationery Catalog Item window to complete the new master catalog item.
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Close the Stationery Master Catalog window to return to the Customer Setup window.

Below the Master button in the Stationery section, you will see a button labeled User.

Click the User button in the Stationery section to bring up the Stationery User Catalog window.
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The Master catalog is a list of items that are configured for a customer that can be used in a User
catalog. Web users are assigned to particular User catalogs to define the products that the web user is
allowed to order. User catalogs are often a subset of a Master catalog, but it is possible to assign all
items in a Master catalog to a User catalog. If your customer is a large company with multiple divisions
that will be ordering from you, you might set up a different user catalog for each type of person that will
be ordering from that company. In cases like this, you might assign a User catalog to a web user that
only contains items from the master catalog that are relevant to the web user's role in the company.
Another approach would be to create multiple user catalogs with each catalog containing particular
categories of items. Then, for each web user, you would assign all the user catalogs that contain items
of the type that the web user would want to order.

In this example, we just want to create a single User catalog that contains the one item that we have
configured so far in the master catalog.

From the Stationery User Catalog menu, choose Commands > New

For the Description on the new user catalog, enter: Xetex Stationery Catalog

Click the New Section Description button, enter Business Cards for the Section Description, and press
the Tab or Enter key on your keyboard.  So far, the Stationery User Catalog window should look like
this:
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On the Stationery User Catalog window, click the New Items button to display the Stationery Master
Catalog Items list.

Double click the XETEX-BC item in the list to select it for the User Catalog.  The User Catalog should
now look like this:
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Close the Stationery User Catalog window to return to the Customer Setup window.

Now that you have a user catalog, you need to link it to a web user.  On the Customer Setup window,
click the Web Users button to display the Web Users window.

Click the Find icon on the toolbar.

On the Find Web User window, enter fhickey for the User Name.
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Click the Search button on the Find Web User window and double click the fhickey record in the
Search Results list to load the record.
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If you followed along in the previous sections, you should see Xetex Warehouse Items and Xetex
Marketing Materials in the Catalog List already.  We need to add another catalog for the Stationery
item that we just configured.

On the Web Users window, click the Add Catalog button.  This will open the Web User Catalog
window.
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On the Web User Catalog, click the binoculars to the right of the Catalog ID.  This will open the Find
Code window.

Double click the Xetex Stationery Catalog item from the Find Code list to close the Find Code window
and return to the Web User Catalog window.

Now that the correct Catalog ID for the user catalog is selected, click the OK button on the Web User
Catalog window to add the catalog to the list.  The Catalog list on the Web Users window should now
look like this:

Close the Web Users window.

Close the Customer Setup window.

On the main Xebra E-Commerce window, click the Refresh Web Site button to send your changes to
the web server.
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After the refresh completes, reload your web site in a browser. If you need to log in again use the
fhickey user and password fred. If you don't need to log in again, click the Home link on the web site to
load or re-load the Home page.

You should see the new Imprint Items menu item.

On the Home page, click the Imprint Items menu item.  This will open the Imprint Items catalog page.
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Click the Order button to load the page where you can enter the variable text to be printed on the card.
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For the first name, enter Kathy.

For the last name, enter Eck.

Select kathy@xebra.com from the E-Mail dropdown list.

Enter 17 for the extension.

Click the Review Proof button to view the Online Proof page.
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The proof image is displayed at the resolution that you specified for this template in the Template
Editor Page Properties.  The web user can view a higher resolution version of the artwork by clicking
the View PDF link below the proof image.

The background image in the PDF will be based on the Target Resolution that you specified and the
variable text will be scalable so the web user will be able to get a closer look at the details if they want
to zoom in.

If the web user notices an error in their typing when they view the proof image, they can return to the
Edit Imprint page to make changes by clicking the Edit link in the item details section below the proof
image.
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The web user can choose a quantity at a specific price from the Quantity drop down list that is based
on the Quantity Restrictions that you entered on the Stationery Catalog Item window.

For this example, 1 BX is fine.

Click the Add to Cart button...

...to add the item to the cart and load the Shopping Cart page.
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For this example, we want to add another business card with different imprint information.  Click the
Continue Shopping button to take you back to the business card item and click the Order button again.

This time, enter the following:
First Name: George
Last Name: Hutchison
E-Mail: george@xebra.com
Extension: 123456

Note that the extension, 123456, is not George's real extension.  Enter this longer number to see how
the horizontal box movement group that you made in the Template Editor works.  Click the Review
Proof button.
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Notice that the Fax number moves to the right to make room for the longer extension.  In this example,
the extension was so long that the fax number is now touching the X in the Xetex logo.

Click the Add To Cart button to add this item to the shopping cart.  You should now have two business
card orders in the shopping cart, one for Kathy and one for George.

On the Shopping Cart page click the Continue Shopping button so that you can add one more card.

Click the Order button on the business card item.

For this example, let's assume that Xetex wants to print some cards without anybody's name or
telephone extension.  These might be cards to hand out at a trade show where no specific sales rep
needs to be the contact on the card.

Leave the First Name, Last Name, and Extension fields blank, but select sales@xebra.com for the
E-Mail address.

Click the Review Proof button to view the Online Proof page.
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Notice that the fax information did in fact move over to the left to fill the gap left by the missing
extension information.  The horizontal box movement group that you made in the Template Editor
along with Link to box setting on the box containing the text, ext., made the handling of the blank
extension number work out to perfection.

Click the Add To Cart button on the Online Proof page.  You should now have three business card
orders in the cart:  one for Kathy, one for George, and one generic sales card.
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Click the Complete Order button to load the Checkout page.

You don't have to enter any additional information on the Checkout page.  Just click the Continue
button to complete the checkout process.

The Order Confirmation page will show the proof images for each card in the order along with quantity
and pricing information.
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Notice that in the image that shows the Order Confirmation page, Sales Tax was calculated as $7.20. 
If the tax location code that you used for your demo XETEX customer was not configured the same,
the Sales Tax and Total that you see may differ.

Now that you've placed the order on the web site, go back to your Xebra Client and go to the main E-
Commerce window.
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Notice that the Unprocessed Activity From Web Site is still showing zero orders for each type.  (If you
don't see zero orders on your Xebra E-Commerce window, you must have Real Time processing
already setup.)

Unless you have Real Time processing enabled, you have to click the Refresh Web Site button to
receive orders from your web server into your Xebra database.  For now, just click the Refresh Web
Site button to receive the order.  After the refresh completes, the Stationery total order count will
change to 3 and the Process Stationery Orders button will become enabled.

When a web user places an order with Stationery items, the order is split into a separate request for
each stationery item in the shopping cart.  In this example, there is one request for the card for Kathy,
one request for the card for George, and one request for the generic sales card.

Click the Process Stationery Orders button to open the Process Stationery Request window.
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The Process Stationery Request window shows the information that the web user submitted with the
order on the web site.  Notice that the Order Information section shows the text that was entered for
the variable fields.

If you want to review the artwork for this stationery request before you process the order, you can do
so using the buttons at the top right of the Process Stationery Request window.



Learning By Example 197

© 2009  Xetex Business Systems, Inc.

The View Image button displays the screen resolution proof.  The View PDF button shows the artwork
background as well as the variable text.  The View PDF (text only) will open a PDF with only the text.

Click the Process button at the bottom of the Process Stationery Request window.

This will open the Create Job - Stationery Request window.

Notice that the Vendor for all line items has defaulted to TESTDIGI.  This is because you entered
Suggested Vendor 1 as TESTDIGI on the Item record.

You don't have to change anything on the Create Job - Stationery Request window.  Click the Create
Job button to open the Create Job Dialog.
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If you are using automatic job numbers, the Job Number will default to the next available job number in
your system.  For this example, change the job number to TESTSTA instead so that it will be easier to
find the job and delete it when you're done testing.

We want to put all three Stationery requests on the same job, so click the Continue E-Commerce
button to move on to the next request with the imprint information for George.

The job will be created and you will be taken back to the Process Stationery Request information for
George's card.

Click the Process button.

On the Create Job - Stationery Request window, click the Add To Job button.
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In the Add To Job Dialog, enter the job number TESTSTA.

Click the Continue E-Commerce button to add the line item for George's card to the existing job and
move on to the request for the generic sales card.
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On the Process Stationery Request window, notice that E-Mail is the only field shown in Order
Information because E-Mail was the only field that was not blank.

Click the Process button.

On the Create Job - Stationery Request window, click the Add To Job button.

On the Add To Job Dialog, enter the Job Number: 

TESTSTA

Since this is the last item to process for this job, click the Load Job button to view the job with all three
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line items.

Notice that the line item Description is the same for each of these three cards, so it isn't very obvious
which one is for Kathy, George, or sales.  One easy way to fix this is to modify the line item
descriptions to add something that uniquely pertains to that particular line item.

Double click the first line item in the list to open the Line Item window for that item.
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Notice that the Image check box is checked.  Click the Image check box to view the picture of the
business card for Kathy.
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Now that you know for sure that this is the line item for Kathy's business card, close the Image window
append "-Kathy" to the end of the first line item description.

Also notice that on this Line Item, the File Attachments check box is checked.

Click the File Attachments check box to view the file attachments for this line item.

Notice the File Name for each attachment.  The first part of the file name is based on the settings in
the E-Commerce master catalog for this item.  This is what these settings looked like.
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The text, Xetex Business Cards, was specified as the Default File Name.  The file attachment for the
PDF with both the text and background is named simply by adding .pdf to the Default File Name.  The
file attachment for the screen resolution proof image is name by adding .png to the Default File Name.
The file attachment that is a PDF with only text is named by adding _text_only.pdf to the Default File
Name.

Also, remember from the Stationery Catalog Item record for this item, attachments of the Screen
resolution proof and PDF with background & text were set to be included with PO emails.  If you
double click the Xetex Business Cards.pdf entry in the File Attachments list, you will see that the
Purchase Order check box is checked.



Learning By Example 205

© 2009  Xetex Business Systems, Inc.

If you were to look at the File Attachment email settings for the Xetex Business Cards.png attachment,
you would see that it is also flagged for inclusion on Purchase Order emails.  If you were to look at the
File Attachment email settings for the Xetex Business Cards_text_only.pdf attachment, you would see
that this attachment is not set to be included on any emails.

Close the file File Attachments window to return to the Line Item window, then, click the Next arrow on
the toolbar to load the next line item on the job.

Click the File Attachments check box to load the File Attachments window for this line item.

Notice that the names of the file attachments for this line item are exactly the same as the names for
the previous line item.  This is due to the fact that each line item is based on the same master Item
record and the same Stationery Catalog Item record.  They are both named based on the same
Default File Name.  This could present a problem on the purchase order email because it would be
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difficult to differentiate between the attachments for each line item because they would have the same
names.  One solution would be to double click on the attachment in the File Attachments list and
modify the File Name for the attachment to be more specific.  For this example, don't change the file
names so that you can see what happens if multiple file attachments have the same name when you
generate the Purchase Order email.

If you view any of the pdf or png file attachments for this line item, you will see that this is the line item
for George's card.  On the Line Item window, append the text "-George" to the first line item
description.

Click the Next button on the toolbar to load the 3rd line item and add the text "-Sales" to the first line
item description.

Close the Line Item window to return to the Xebra Order Entry window.  It should now be easy to see
which line item is which.

Before you make the purchase order for this job, there is a simple modification you can make to the
Purchase Order document configuration that will enable the PO document to list the file attachments
for each item.  This could be helpful to the vendor so that they can see clearly which file attachments
belong to which line item on the PO document.

If you aren't the person that manages document configurations for your system, then you might not
want to make any changes to the document configuration at this time.  Even if you are the person in
charge of document configurations, you might want to wait to make any changes until you are sure that
other people aren't going to be confused by the changes.  You can just read through the instructions
so that you understand how it would work and if you like the modification, you can make the changes
for real later or ask the person in charge to make the changes for you.

From the Go menu, select Setup.

From the Xebra Setup menu, select Printing > Document Setup.



Learning By Example 207

© 2009  Xetex Business Systems, Inc.

On the Document Types window, double click Purchase Order in the Select a document type list.

This will open the Document Configurations window for the Purchase Order document type.
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Your Configurations list for the Purchase Order document might be different than the one shown if you
have already modified your configurations.  If you want to make changes to your main configuration for
the purchase order, double click the configuration that has both Enabled and Default checked.  This
will open the Document Configuration Editor window for your configuration.

You should see a box in the line item detail section of the configuration that contains the field
[ITEM_VENDOR_INSTRUCTIONS].
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Double click this box to open the Data Field Properties window.

In the Text/Data field, add a new line with the text:

File Attachments:

With the cursor blinking after the new "File Attachments:" text, scroll through the Available Data Fields
lists until you find the field, ITEM_EMAIL_ATTACHMENTS.  Double click on this available field in the
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list to add it to your Text/Data field.

Click the OK button on the Data Field Properties window to save the changes and return to the
Document Configuration Editor window.  Purchase Order documents configurations have multiple
page types.  The first page type will be used for line items that don't have specifications.  Click the
Next button in the toolbar to load the next page type.

The 2nd page type of the Purchase Order configuration is for line items that do have specifications.
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To be sure to show email file attachments for all line items on a purchase order document, you would
have to add the [ITEM_EMAIL_ATTACHMENTS] field somewhere on this page type.

Note: The Xebra Document Configuration Editor allows for a lot of flexibility in how your documents will
look.  The preceding example only shows one way of adding the ITEM_EMAIL_ATTACHMENTS field
to the Xebra Standard document configuration for the Purchase Order.  There are lots of ways that you
could do this and it is up to you to decide how your documents should look.

After you make the changes to your document configuration, you can close the Document
Configuration Editor window and save the changes.  Close the other open windows until you get back
to the Xebra Setup window and then use the Go menu to return to Xebra Order Entry.

From the Xebra Order Entry File menu, select TESTSTA - XETEX from the recent jobs list to re-load
the TESTSTA job.
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With the TESTSTA job loaded, from the Xebra Order Entry Actions menu, choose Prepare Vendor
Purchase Order.

From the Prepare Vendor Purchase Order window, click the Create Purchase Order button in the
toolbar.
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This will open the Purchase Order Editor window.
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Notice that the names of the file attachments that will be included in the Purchase Order email are
shown below the Special Instructions.  Also note that the names of the file attachments are slightly
different than what you saw on the Line Item File Attachments window.  Since there were multiple file
attachments flagged to be emailed with the same name, Xebra modified the names by adding a
sequential number to each one that would have been duplicated.  
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Click the Save button on the Purchase Order Editor toolbar to finalize the purchase order and open it
in Xebra Print Preview.

To email the purchase order to the vendor, click the email button from the Xebra Print Preview toolbar.

The email should open in the default email client for your computer.  The following image shows the
email in Windows Mail.
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Notice that the artwork files are attached and named as they were shown on the purchase order
document.  The Job TESTSTA.pdf file is a PDF version of the purchase order document.  From this
point, you could alter the text of the email and you could send the email.  Since Test Digital Printing
Co. isn't real and this isn't a real order, don't try to send the email.

Close the email without sending.

Close the Xebra Print Preview window.

Close the Prepare Vendor Purchase Order window.

Since the TESTSTA job is just an example, it would be good to remove it from your live system.  Click
the red X on the Xebra Order Entry toolbar to remove the job.

NOTE:  If the red X is disabled, you will need to find a Xebra operator in your company with the correct
security privileges to delete the job.
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3.2 Removing Test Data

If you followed along with the Learning By Example section, you may have left over test data in your
system that you should remove.  The following are instructions for making sure that the test data gets
cleaned up.  In some cases, your operator security settings may prevent you from deleting particular
data.  In these cases, you will have to find a person at your company who is authorized to delete the
information.

Go > Xebra E-Commerce > Actions > Customer Setup
Enter XETEX for the Master Customer.

In the Warehouse Release section, click the User button.
Choose Commands > Next from the menu to load the first user catalog for XETEX.
Choose Commands > Delete to delete the user catalog.  Answer Yes to the warning message.
Close the Warehouse Release User Catalog window.
In the Warehouse Release section, click the Master button.
Double click the XETEX-ENV-9W item to open the Warehouse Release Catalog Item window.
Click the Delete button on the Warehouse Release Catalog Item window.
Close the Warehouse Release Master Catalog window.

In the Stock Sales section, click the User button.
Choose Commands > Next from the menu to load the first user catalog for XETEX.
Choose Commands > Delete to delete the user catalog.  Answer Yes to the warning message.
Close the Stock Sales User Catalog window.
In the Stock Sales section, click the Master button.
Double click the XETEX-TSPC item to open the Stock Sales Catalog Item window.
Click the Delete button on the Stock Sales Catalog Item window.
Close the Stock Sales Master Catalog window.

In the Stationery section, click the User button.
Choose Commands > Next from the menu to load the first user catalog for XETEX.
Choose Commands > Delete to delete the user catalog.  Answer Yes to the warning message.
Close the Stationery User Catalog window.
In the Stationery section, click the Master button.
Double click the XETEX-BC item to open the Stationery Catalog Item window.
Click the Delete button on the Stationery Catalog Item window.
Close the Stationery Master Catalog window.

Click the Web Users button.
Choose Commands > Next from the menu to load the first web user for XETEX.
Choose Commands > Delete to delete the fhicky web user.

Close the Customer Setup window.

From the Go menu, choose Setup 
From the Xebra Setup > Options menu choose Delete Customer Specific Inventory Item
Enter XETEX-ENV-9W for the Item code and click the OK button.

From the Go menu, choose Order Entry.

Choose Commands > Find Job from the menu.
Enter TESTSS for the Job Number and click the Search button.  If a record is found, load it and delete
it.
Repeat this to delete job TESTSTA if it still exists.

From the Order Entry View Menu, choose Item
Choose Commands > Find from the menu.
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Enter XETEX-BC for the item code and load and delete the record.
Repeat this to delete items: XETEX-TSPC and XETEX-ENV-9W
If you created a POSTAGE item and you don't want to keep it, you can delete that record too.

From the Order Entry View Menu, choose Vendor > Remittance
From the Vendor Remittance > Commands menu, choose Find.
Enter TESTDIGI for the Code and load the record.
Choose Commands > Delete from the menu to delete the TESTDIGI record.

From the Order Entry View Menu, choose Vendor > Ordering
From the Vendor Ordering > Commands menu, choose Find.
Enter TESTDIGI for the Code and load the record.
Choose Commands > Delete from the menu to delete the TESTDIGI record.

From the Order Entry View Menu, choose Customer > Billing
From the Customer Billing > Commands menu, choose Find.
Enter XETEX for the Code and load the record.
Choose Commands > Delete from the menu to delete the XETEX record.

From the Order Entry View Menu, choose Customer > Shipping
From the Customer Shipping > Commands menu, choose Find.
Enter XETEX for the Code and load the record.
Choose Commands > Delete from the menu to delete the XETEX record.

If you entered a PST product category for postage and you don't want to keep it:
From the Order Entry View Menu, choose Control Files > Product Category
Choose Commands > Find from the menu
Enter PST for the Product Category Code and load the record.
Choose Commands > Delete to delete the PST record.
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4 Advanced Setup Options
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